Outlook 2010 and plugin



  • Plugin doesn’t even work in 2010… understandable as 2010 moved outlook to the ribbon. I assume this will be fixed, but I thought I’d give a heads up.



  • Hi,
    I found the plug-in does work, You need to use backstage (file) - Options - addin - then click add-in-options
    With PA Outlook installed it should bring up a dialogue box.



  • Well i also found the plugin not working… Hm
    Will try it latter.



  • I think the problem only occurs using the x64-Version of Microsoft Office 2010. I haven´t tried the x86-Version yet, but it looks like this would be the problem.

    This problem also affected Apple using iTunes Plugin. The x86-Version ran fine, but the x64 wont. (for syncing data for example)

    I hope that ConeXware will compile the component for x64 so this nice component will be supported by Office.

    @ x86 Users

    It would be helpful if you could the test your Ofice-Plugin with your installation. I am using latest Outlook 2010 with latest (today downloaded) PA for Office withing x64 and it wont work.

    Thanks for you help!


  • conexware

    Unfortunatly there is one big problem with that - Delphi currently does not have 64bit compiler so it is impossible to just recompile our code.

    Likely solution will have to be us moving to different codebase for PAOP in the future, that will support both.



  • @spwolf:

    Likely solution will have to be us moving to different codebase for PAOP in the future, that will support both.

    thanks.
    good plans



  • May be for Outlook x64 simple to create VBA code, like this for WinZIp?

    Sub ActiveWorkbook_Zip_Mail()
    'This sub will send a newly created workbook (copy of the Activeworkbook).
    'It zip and save the workbook before mailing it with a date/time stamp.
    'After the zip file is sent the zip file and the workbook will be deleted
    from your hard disk.
    Dim PathWinZip As String, FileNameZip As String, FileNameXls As String
    Dim ShellStr As String, strdate As String
    Dim Runwzzip As Long
    Dim OutApp As Outlook.Application
    Dim OutMail As Outlook.MailItem
    
    PathWinZip = "C:\program files\winzip\"
    'This will check if this is the path where WinZip is installed.
    If Dir(PathWinZip & "winzip32.exe") = "" Then
    MsgBox "Please find your copy of winzip32.exe and try again"
    Exit Sub
    End If
    
    esaName = ActiveSheet.Range("f6").Value
    seqNumber = ActiveSheet.Range("b6").Value
    FileNameZip = "C:\rds\zipped\" & seqNumber & " " & esaName & ".zip "
    FileNameXls = "C:\rds\zipped\" & seqNumber & " " & esaName & ".xls"
    ActiveWorkbook.SaveCopyAs FileName:=FileNameXls
    
    ShellStr = PathWinZip & "Winzip32 -min -a " _
    & " " & Chr(34) & FileNameZip & Chr(34) _
    & " " & Chr(34) & FileNameXls & Chr(34)
    Runwzzip = Shell(ShellStr, vbHide)
    
    nSubject = ActiveSheet.Range("b6").Value
    Set OutApp = CreateObject("Outlook.Application")
    Set OutMail = OutApp.CreateItem(olMailItem)
    
    With OutMail
    .To = "Email here"
    .CC = ""
    .BCC = ""
    .Subject = nSubject
    .Body = " "
    .Attachments.Add FileNameZip
    .Send
    
    End With
    
    Set OutMail = Nothing
    Set OutApp = Nothing
    Kill FileNameXls
    
    End Sub
    


  • i am an x86-user and i can not get the plugin to work with outlook 2010 under win 7 pro.

    i can install it - no problem. when i take a look at my add-ins, i get the same two screens like pjb.

    so far so good, now my two problems start.
    first i can not get the plugin to work. when sending an e-mail it does simple nothing.
    second, it destroyed all other plugins. i can click every add-in i like and always end up with the option dialog from powerarchiver. so, as long as the pa add-in is installed i can not configuer any other add-in.
    deinstalling the powerarchiver add-in get my other add-ins working again.

    so, it does not look like a 32/64-bit problem.
    for me, it looks like a general problem with the plugin.


  • conexware

    @new_kid:

    i am an x86-user and i can not get the plugin to work with outlook 2010 under win 7 pro.

    i can install it - no problem. when i take a look at my add-ins, i get the same two screens like pjb.

    so far so good, now my two problems start.
    first i can not get the plugin to work. when sending an e-mail it does simple nothing.
    second, it destroyed all other plugins. i can click every add-in i like and always end up with the option dialog from powerarchiver. so, as long as the pa add-in is installed i can not configuer any other add-in.
    deinstalling the powerarchiver add-in get my other add-ins working again.

    so, it does not look like a 32/64-bit problem.
    for me, it looks like a general problem with the plugin.

    what other plugins do you have installed? maybe it is clashing with one of them…


 

0
Online

9.8k
Users

6.0k
Topics

36.7k
Posts