-sep parameter broken?



  • I am trying to use pacomp with the -sep parameter to create a separate zip file for each source file. But when I specify a file mask that matches multiple files, only one zip file is created, for only one of the intended files.

    Assume the current directory contains five .txt files. After running the following command, five zip files should be created:

    pacomp -a -sep ignored.zip *.txt
    ```- or -
    

    pacomp -sep ignored.zip *.txt

    (The -a option seems to have no effect with -sep. Both versions produce the same result.)
    
    Result: In both cases **only one zip file is created,** containing one of the text files.
    
    Expected behavior: every file matching the mask *.txt should be compressed into an individual .zip file, so the example commands should create five separate zip files.
    
    Am I using the parameters incorrectly, or is it a problem with pacomp? I really, really need this to work :)


  • Yes. Reproduced with PACL 7 beta 1.


  • conexware

    thanks fellas, writing it up!



  • I believe this is fixed in PACL 7 (Release Candidate).


  • Alpha Testers

    Tested in PACL 7.00 RC1 and the sep parameter now works correctly.

    Bug fixed confirmed

    Kind Regards
    Micke


Locked
 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts