Deleting folders doesn't work if more than one folder is selected.



  • Deleting folders doesn’t work if more than one folder is selected in a zip file.



  • what operating system how big is the archive what files names are used within the archive and how much size is free on your hard drive



  • @harry:

    Deleting folders doesn’t work if more than one folder is selected in a zip file.

    this works for me in the newest alpha 11



  • @davidsplash:

    what operating system how big is the archive what files names are used within the archive and how much size is free on your hard drive

    File size was about 170 MB, ca. 9000 files, frees space about 11 GB
    Im’m using PowerArchiver 9.2 on XP SP2.
    There was no message indicating any error. It just didn’t work.

    I attached part of the file list.
    And a screenshot what I did (sorry it’s german UI).

    After clicking delete - a dialog apears - select files - OK
    then there is some processing …
    and finally the folders are still there

    BTW: Today I discovered that the folders I delete are only visible in explorer style view.
    attachment_p_3934_0_harry.zip



  • @harry:

    Today I discovered that the folders I delete are only visible in explorer style view.

    Strange, from the snippet.txt they are not empty and so should be visible in Classic view (enable View details) - under “path” just like in the txt file.



  • @TBGBe:

    Strange, from the snippet.txt they are not empty and so should be visible in Classic view (enable View details) - under “path” just like in the txt file.

    what I meant is that the explorer view show’s all subfolders of the current folder on top of the files. The classic view doesn’t show folders only.
    See my screenshot.gif from above post in the right pane, folders are from _spec to zlib, files are _clear.bat and below.

    It seems that PA is doing search and delete but doesn’t find anything for sqlite3.0.8/* sqlite3.1.6/*.
    Whole processing takes some minutes.

    While repeating this step I had another idea:
    Show a summery of how many files added/deleted/updated after processing in status bar.



  • @harry:

    Deleting folders doesn’t work if more than one folder is selected in a zip file.

    I have tried some tests of this in PA 9.20.

    Using either Explorer or Classic view, the folder contents/files are deleted but the folders themselves are not.
    I think the problem is caused by folder names with ‘.’ characters as when I renamed the folders (before creating the zip file) then deleting folders worked.
    @klumy:

    this works for me in the newest alpha 11

    So will be fixed in next version of PA (when it’s ready).

    @harry:

    BTW: Today I discovered that the folders I delete are only visible in explorer style view …… The classic view doesn’t show folders only.

    Classic view doesn’t show folders at all - it only shows the files with pathnames. I thought you were saying the path names were not shown.


  • conexware

    Check this release out and see if it helps:
    http://www.powerarchiver.com/test/release/powarc925.exe

    This is 9.25 beta thats going to be published in a day or two.

    thanks,


 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts