Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Errors during compression.



  • Mostly as of late I have only archived single files about. But recently I have been trying to archive folders.
    Both .pa and .7z causes unable to write to file / harddisk error and memory errors and crashes.

    First I thoguth it was due to time to dust off the computer, and that it might getting heated.

    Problem remained tho, so for some reason I tested zip, plain old trusty zip.
    It now works and x100 faster then either .pa or .7z.

    I got a bit curious if it could be due to file and folder handling, so I tested to .pa and
    .7z archive the folder the other archives was in. This worked.

    So either my computer smack do not live up to the spec to use .pa and .7z or
    .pa and .7z have a problem with files and folders in combo.

    I’m not sure how to continue from here to pin point fore sure what it is due to.


  • conexware

    @Suranappar_Micke said in Errors during compression.:

    Mostly as of late I have only archived single files about. But recently I have been trying to archive folders.
    Both .pa and .7z causes unable to write to file / harddisk error and memory errors and crashes.

    First I thoguth it was due to time to dust off the computer, and that it might getting heated.

    Problem remained tho, so for some reason I tested zip, plain old trusty zip.
    It now works and x100 faster then either .pa or .7z.

    I got a bit curious if it could be due to file and folder handling, so I tested to .pa and
    .7z archive the folder the other archives was in. This worked.

    So either my computer smack do not live up to the spec to use .pa and .7z or
    .pa and .7z have a problem with files and folders in combo.

    I’m not sure how to continue from here to pin point fore sure what it is due to.

    Hello, it might be due to big filelist or some specific filename in that list? How many files are you individually adding? There is a big difference between those two, because when you select main/root folder it sends only a single path to the engine, while if you select multiple files inside then it has to send those multiple files. It might be an issue with some filename causing a problem or something like that.

    As to the speed, try using Optimized Fast instead of Strong, and use Normal or less to get fastest possible speed. It is faster than zip and compresses better too. Let us know!

    Also let us know what OS, cpu, RAM, etc, are you using, all the juicy info, that could help us to pinpoint the issue. Thanks.


  • conexware

    @Suranappar_Micke if you can provide more info it would be helpful for our debugging. I have tried adding 300,000 files to the list and I cant get errors like this… you can try latest release as well:
    https://forums.powerarchiver.com/topic/5738/fast-ring-powerarchiver-2017-17-00-64

    thank you!


  • conexware

    We found one issue with 7z engine and fixed it in .90. Let us know if it is better for you. It was dependent on special circumstances and very hard to reproduce. Thank you!


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.