Problem with large, spanned, encrypted, 7z archive.

  • I spent many hours trying to figure out how to use PACOMP to add about 50 Gb to a spanned 7z archive with AES256 encryption, and have yet to be successful.

    I’ve tried every combination of switches I can think of, with no success. Can someone offer a combination of switches that is known to work for this kind of task?

    All I have been able to make is a set of spanned files that PA cannot open.

  • conexware

    We will test this out, 2-3 days ago someone reported an issue with large 7zip spanned archives…. thanks.

  • I should have given you more information in my first post, so I’ll try to do that here.

    I have a batch script that includes the following command:

    pacomp -a -P -g -cz -ca -$"%TEMP%" -v%CHUNKSZ% -x@%EXCFILE% -l"%BULOG%\PA_%MON%%DAY%%TM%Log.txt" "%BUTEMP%%MON%%DAY%%TM%.7z" @"%SCRIPTPATH%%BULOG%%MON%%DAY%_%TM%.txt"

    The same command with the variables defined appears as (example):

    pacomp -a -P -g -cz -ca -$C:\WINDOWS\Temp -v100M -x@exclude.txt -l"BackupLogs\PA_12_03_0453PM_Log.txt" “Z:\BackupTemp\12_03_0453PM.7z” @C:\Users\User\Documents\SystemScripts\BackupLogs\12_03_0453PM.txt"

    During the testing of this command, I did not specify any encryption. The archive files were going to be encrypted by Windows native CIPHER (EFS), and then copied to another host using ROBOCOPY /EFSRAW.

    The @list argument at the end of the command line is a text file that is generated with other tools throughout the day. It’s essentially a file that contains a list of thousands of lines, each line a fully defined path name without quotes. For example, one entry in the list would be:

    C:\Users\User ABC From Unit 123\Documents\FileName.pdf

    I also tried:

    pacomp -a -P -v50M
    pacomp -a -v100M
    pacomp -c2 -P -v100M
    pacomp -a -P -g -v100M
    pacomp -a -P -g -c2 -e2 -v100M

    In each case, PACOMP would run for about twenty minutes, using all the CPU it could, then either terminate without any error, or produce a generic error that I didn’t write down and terminate. In every case, it never created any archive files. The only thing it created was most of the header of the log file.

    I then tried to use PA 2013 Pro to do the same thing to see if it would work. From the Home tab, I created a New archive with the following options:

    Type: 7-zip
    Action: Add
    Method: Optimize
    Compression: Maximum
    Encryption: AES 256
    Encrypt Filenames: Yes
    File Paths: Store Full Paths
    Include Subfolders: Yes
    Include System and Hidden Files: No
    Create Solid Archive: Yes
    Encrypt Archive: No
    Multiple Disk Spanning: Custom
    Volume Size: 100000
    VSCS: Smart

    I selected the same folders for archiving as was specified for PACOMP. The amount of data this represents is about 50 gigabytes. PA Pro ran for about an hour, and it produced 256 (.000-.255 - interesting coincidence, or is this a limit?) volumes and completed successfully. However, when I attempted to open the archive, PA Pro indicated that it could not open the file because it was invalid or something like that. Again, I didn’t write it down.

    This is from my memory, so it might not be perfectly accurate. If there’s any testing or diagnostic information you would like me to provide, just let me know.

    Oh, and I’m running this on Windows 8.1 Professional 64-bit.

  • conexware

    We were able to confirm this issue and it has been logged in.
    Thanks for the details :)

  • Latest version v8 Beta 1 can do the job!

  • conexware


    Latest version v8 Beta 1 can do the job!

    let us know if you find anything else. Thanks!

Log in to reply