"Hide filename" not available under encrypt 7zip format



  • In the past I used 7ZIP and was able to hide filenames during encryption of an archive. I bought PA (13.02.02 09/2012) believing that was also possible, reading the manual pages and online help. But when I select Encrypt, and then 7ZIP format, I cannot see “hide filename” as an option. It only exists if you choose PAE as an output format.

    Bug? Its very helpful to hide the filenames as it clearly makes it harder to decrypt if you have no clue as to possible contents of each sub-file.

    Mike
    BTW - the captcha requirement on every post … a bit excessive, and some of them are pretty hard to read as a human!



  • Right click a file or files > “Compress To…” > “Compress With Options…” > Select format: “7-ZIP” > Encryption: “AES 256-bit” > check “Encrypt filenames”.

    The “Encrypt Files” dialogue in the main program window should probably be updated to include this option. I assume that is what you are using.


  • conexware

    thank you, we will check it out…



  • @iDunk:

    Right click a file or files > “Compress To…” > “Compress With Options…” > Select format: “7-ZIP” > Encryption: “AES 256-bit” > check “Encrypt filenames”.

    The “Encrypt Files” dialogue in the main program window should probably be updated to include this option. I assume that is what you are using.

    Thank you - I can confirm this method works as you describe. And yes, I would certainly appreciate the option being included in the main program, which is what I tend to use.



  • No problem. In case you want to compress and encrypt files or folders, there is the right-click method (also available from within PA main window), and there is the “New” > “New archive…” method, with a different dialogue, where “Encrypt filenames” is also available.

    “Encrypt files” is mainly useful if you want to encrypt files which already are archives. However, it would be useful to have the option to encrypt filenames in this dialogue, too.


  • conexware

    Here is a test screenshot of 13.02.02 creating a new 7Z archive through main PA.
    As you can see the “Encrypt Filenames” option is available and can be checked when encryption is selected.
    I am assuming that you might have selected the Zip format which is why the “Encrypt Filenames” option is not available.
    When entering the name of your archive, please select the 7Zip format in that same dialogue just below the file name field and everything should appear as in the screenshot.

    🙂
    attachment_p_30257_0_ef.png



  • idunk - thanks again - your suggestion works.

    Mili - your scenarios are correct, but here are two where “encrypt filenames” is not available, though it should be.

    Create a new 7ZIP empty archive, without encryption.
    Drag a file into the window, the attached popup appears. Select encrypt - filename option not available.

    Create a 7ZIP unencrypted file with some content (a single file) or open an existing 7ZIP file.
    Select Encrypt from Tools menu. Attached pops up - select 7ZIP, Encrypt AES - filename option again not available. This is the more common situation for me where I want to simply encrypt some archives and not others, that have been previously created.

    attachment_p_30258_0_dragged.jpg
    attachment_p_30258_1_existing-7zip.jpg


  • conexware

    great finds Morph!
    logging them in 🙂



  • Wow, I’ve never even seen the Drag and Drop screen before. I guess we all have our own way of using our tools 🙂

    The dialogue in the second screenshot was the one I assumed you were using.


  • conexware

    Added Encrypt Filenames option to the latest update, Drag and Drop window… please update via patchbeam and let us know. Thanks!


 

9
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy