Permission issue on ZIP file after using PACL in XP Mode

  • On my host system, I am using Windows 7 Enterprise 64-bit. It is fully updated. I have PowerArchiver 2010 Free (v11.63.12) installed. I also have the latest version of PACL (v6.01) installed.

    So that I can still use some old 16-bit DOS programs, I have XP Mode installed. On it, I have PACL v6.01 installed as well (thought I DON’T have the windows program [PowerArchiver 2010] installed on it).

    I also have the C drive of XP Mode mapped to the Z drive of my host machine, allowing me to access files from the XP Mode machine from a drive letter on my host machine.

    Now for the problem–anytime I compress a file in XP Mode using PACL, I am not able to access it from the Host machine. Two examples: (1) if I open up the XP Mode drive in an explorer window of the host machine and double click on the newly created ZIP file, it will open PowerArchiver 2010, but the contents will be blank, (2) if I attempt to attach the newly created ZIP file to an email (in Thunderbird), I get a message saying, “You don’t have permission to open this file.”

    I should point out that this seems to happen ONLY to files created with PACL (and only those created in XP Mode). I used to use PKZIP for DOS v2.50 to compress files from the command line. I gave it a try in XP Mode, and it allows me to do all of the above to which PACL created files are giving me issues. I also have used PACL on the host machine, and, again, no issues.

    Any advice would be extremely appreciated!


  • conexware

    what are the user permissions on those files that wont be opened? Can you change them by using file property in Windows Explorer?

  • Spwolf–you are a genius. My XP Mode is not joined to a domain, thus “Simple File Sharing” was enabled by default. As a result, I didn’t have a Security tab when looking at the properties for the shared drive. And it didn’t even occur to me to enable it until I read your post.

    So I disabled “Simple File Sharing,” went to the Security tab for the shared drive, and changed the needed permissions. And it worked. Thank you.

    Just curious, though, why would the lack of appropriate permissions affect ZIP files created with PACL but not, for example, those created with PKZIP for DOS?

  • conexware

    probably for some compatibility reasons with old programs, I am not sure myself. But that was the first area I would look at… thanks!

  • I hate to bring this up again, but I’m experiencing the same problem in XP Mode again. I’ve figured out that when I change the security permissions, it effects only files already on the XP Mode hard drive, not those created after setting the permissions.

    So, in other words, since I’ve already set the permissions to allow me access to the files, if I create a new file using PACL, I then have to set the permissions yet again to be able to access that file from the host machine. And I would have to do this after every new file I create.

    I would normally think this is a Windows issue (since it deals with security and permissions); however, files created with PACL seem to be the only ones affected (not even ZIP files created with PKZIP for DOS are affected). So I’m hoping someone here would be able to shed some light on how to solve this.


  • I think I finally figured it out…

    A friend of mine suggested the following for the security settings in XP Mode:

    "Is inherited permission under security, advanced? perhaps it lost the inher. permissions and the rights aren’t “trickling” down. "

    It worked. Yay!!!

  • conexware

    basically user that accesses the drive, should be able to access files created by the “user” that is creating the files. I personally set it up so they use that is accessing the drive is same username as user on that XP Mode OS.

    I dont think it is anything other than files being owned by another user. Something that application working in 16 bit compatibility mode might not set properly at all.

  • conexware

    ah you figured it out… as we europeans would say, Super!


Log in to reply