PA 2007 B10 context menu entries missing (Vista x64 german)



  • Hello

    I installed PA 2007 Beta 10 on the german Windows Vista Ultimate x64 today.

    Even I had the impression (maybe I’m wrong) that the context menu did work in the beta version of Vista it does not work anymore.

    Maybe the problem lies in the fact that even I select “program files” PA gets installed in “program files (x86)”. I tried “progra~1” which resulted in the right “program files” directory, however, the context menu isn’t working.

    Given other topics concerning context menu I searched the registry and found a key starting with “{d03d3…}” in which the pashelext.dll is mentioned.

    Any suggestions ? Or things I can provide to find a solution.


  • conexware

    Hi,

    we will check it out… I thought it was working? Was this your first PA install on that computer?



  • Yes.

    Windows XP is still on another (physical) harddrive but the Vista OS is on it’s own drive and was installed as “clean” installation.

    Another idea: If Vista forces the install dir to be “program files (x86)” maybe the routine in the setup which selects the pashellext.dll version to be copied selects the x86 one.


  • conexware

    @Henry_Jones:

    Yes.

    Windows XP is still on another (physical) harddrive but the Vista OS is on it’s own drive and was installed as “clean” installation.

    Another idea: If Vista forces the install dir to be “program files (x86)” maybe the routine in the setup which selects the pashellext.dll version to be copied selects the x86 one.

    I personally forgot how it goes with 64bit, but other members of the team have PA 2007 working on 64bit. So it might be something with german setup.

    Can you check english setup and see how it works?

    thanks,



  • Surprisingly the english setup works.

    It still goes to “program files (x86)” even I select otherwise but the context menu is working.


  • conexware

    please check with RC1… thanks



  • Checked with RC1 just now.

    It works partly. The normal context menu is working in german now.

    The “drag and drop” menu is still missing. I forgot to test this with beta 10 but in RC1 it is missing in the english version as well.

    Maybe there is something to configure to make this menu show up which I’ve missed so far ?

    For me PA is now useful again (or the first time with Vista x64), thanks to the fast response.

    If there is something to try about the drag’n’drop Menu let me know.

    BTW, in the german (or maybe international) version the option “reuse window” does not work. Or better, as far back as I know it never did. Personally this is more a cosmetic thing anyway.


  • conexware

    drag and drop with the shell (works only in extraction)? I am not sure if functionality was implemented in x64 extensions, since they are completly different… Ivan will respond to that…

    Reuse seems to work with english, will check with german…


 

4
Online

9.8k
Users

6.0k
Topics

36.8k
Posts