PA fails to run after install on non-admin accounts



  • I use PA at my university. Students have a limited user account.
    I always install PA to the desktop, since I have write access there.

    When I install PA 9.6 (beta 2 or 3), I get file error messages on WBHELP2.DLL and WBOCX.OCX, access is denied, so cannot write to windows directory.

    Now when I try running PA, PA crashes with “PowerArchiver 2006 has encountered…… We are sorry for the inconvenience.”

    I can bet that the WindowBlinds skin engine is causing this! Even if I remove all PA entries from the registry (the admin missed something…), or delete the Skins folder, it still happens.
    No other version of PA does this, but 9.6.

    I dunno how this can be solved; maybe you shouldn’t initialize the skin engine if there is no skin selected, which is the default.

    PS: why not install the WB files in the PA dir? PA is the only app that needs to use those files!


  • conexware

    we cant add it to any other folder. Thats the way it works. So you have to have an admin account to install it.


  • conexware

    With 9.6 final, PA will skip around missing dll’s and continue working…

    thanks



  • Thanks!

    Until the problem is fully resolved, I’ll have to use 9.51 on campus and 9.6 at home… 🙂



  • OK, the problem is solved - PA runs!!!

    If I try to select a skin, nothing happens!!

    Great work!!! 😉


Locked
 

8
Online

9.8k
Users

6.0k
Topics

36.8k
Posts