7z archives kill PA



  • The attached archive, created with PA 9.20.07 (ultra compression, solid archive), will cause PA to exit abruptly when testing or extracting. The command line 7z utility (version 3.12 from 7-zip.org) has no problems extracting or testing it. If I don’t use the “solid” option, the problem does not occur (at least not with this particular set of files).

    This problem happens to me quite frequently. In fact, I find that it’s pretty much guaranteed to happen if there are enough files in the archive, so the number of files seems to be a factor (I often create archives with many small files). This problem also occurred with the previous version of PA, and happens with files created by 7z.exe (version 3.x or 4.x). I’m using WinXP pro with SP2 and all the latest patches.

    Thanks!



  • Ok, so apparently I’m not allowed to upload anything larger than 100k, which makes it pretty much impossible to post an example of an archive that causes the problem I mentioned. However, considering how often it happens to me, it can’t be that hard to reproduce, so try this: get a medium to large set of source code files and compress them using 7z, ultra, solid archive and you should have no problem reproducing the problem. For example, you could try the boost c++ library (www.boost.org), which contains over 9000 files.



  • Works For Me - PA 2.20.07 😕
    Win XP SP-1

    Downloaded “boost_1_32_0.tar.bz2” and extracted to subfolder boost_1_32_0

    1. Folder boost_1_32_0 : Shell extension -> Compress to 7z + options
      Set => Ultra ; Include Subfolders ; Solid
      Not Set => Save full folder info

    After compression complete : Test and Extract works OK.

    1. Open Folder boost_1_32_0
      Ctrl-A : Selects files & folders : Shell extension -> Compress to 7z + options
      Set => Ultra ; Include Subfolders ; Solid
      Not Set => Save full folder info

    After compression complete : Test and Extract works OK.

    Note:
    PA Options : configuration : Miscellaneous : normal relative path => NOT set
    No compression profile for 7z.

    Are any of these the settings you use?



  • Today I tried the same steps you did, with the same settings and the exact same file, but unfortunately I get the same result as before 😞 Maybe it’s related to SP2?



  • @binkley:

    …Maybe it’s related to SP2?

    Maybe, but more likely something else.
    Do you antivirus which is checking files on use?
    As a check, turn off any AV and try again.

    There were problems with some AV reported previously, so it is worth checking.
    As an example, see also http://www.powerarchiver.com/forums/showthread.php?t=242



  • No, I have no AV software on my system. As an experiment, I tried the same test on two other machines. One was also WinXP SP2, the other was Win 2K. I got the same result both times: testing the archive causes PA to exit abruptly, extracting results in some files being extracted and then it again exits abruptly. These are all pretty generic installations of PA. In particular, I didn’t change any configuration settings for the Win2K test except to enable “create solid archive” when I created the archive. None of these machines have any AV software either.


  • conexware

    Hi,

    Try reseting to default settings and then try opening/extracting again, does it work?

    Also, try slightly newer version of PA 9.2:
    http://www.powerarchiver.com/test/release/powarc921.exe

    And see if it helps. It shouldnt really, but…

    thanks,



  • I uninstalled 9.20.07, deleted the install dir, then installed 9.21 (this is on the win2k machine). Here are the results of opening and testing archives created with various compression settings (all archives created with 9.21):

    ultra + solid: crash
    ultra + no solid: OK
    max + solid: crash
    max + no solid: OK
    normal + solid: OK
    normal + no solid: OK
    fast + solid: OK

    I’m assuming that uninstalling and deleting the install dir before reinstalling will cause it to reset the settings, since it didn’t remember the window position after I did this. Otherwise I don’t know how to reset all the settings to their default states.

    All archives were created using the files extracted from boost_1_32_0.tar.bz2



  • Tried again on Win XP Home SP2 (using 9.21 - thanks spwolf).
    Still no problems with either test or extract. 😕

    @binkley:

    I tried the same test on two other machines.

    Hmm - I was going to ask about free disk space or RAM installed because I know PA has had “problems” before if the disk fills up whilst it is running.
    But not sure if that is relevant now 😞



  • Hmm… no, it’s not disk space. The win2k machine is a bit low on disk (~2.5 GB free) but it’s definitely not out, and the other two have plenty of disk. The XP machines have 1 GB of ram each, the win2k machine has 512 MB. None of the machines are overclocked, nor are they having any other unusual problems.

    😕



  • @binkley:

    Today I tried the same steps you did … [snip] … uninstalling and deleting the install dir before reinstalling will cause it to reset the settings

    My steps were using explorer shell … but this “rang a bell” and now I have found how to get the crash.

    I always use “classic” but the default is with “explorer” view.
    So instead of using Explorer shell extensions, I started PA (9.21).
    Enabled “Explorer View”.
    Now create the 7z archive within PA window.
    On compression completing, I clicked test … and PA disappears (crash)!
    Restart PA, open the archive and press test … and PA disappears (crash)!
    Restart PA, switch to “classic view” open the archive and press test … and PA disappears (crash)!

    Test archive from explorer shell - no problems.
    Basically, it seems that the problem is only when using PowerArchiver and not shell extensions.



  • This seems consistent with what I’m seeing. In all my experiments I created the archive by using the shell extensions (since that’s the way I usually work), but always double clicked it (to open PA) and then did Actions -> Test to test it, or the toolbar extract button to extract. I must have previously disabled “Test” for shell extensions, or it is not enabled by default, so testing it that way didn’t occur to me.

    Good to know I’m not going completely crazy 🙂



  • it could be bad memory on your computer causing the problem



  • True, but it’s unlikely that the same problem would happen on all three (four, counting Terry’s computer) different computers. Also, I’ve run memtest86 on two of these machines within the past 6 months and it didn’t find any problems.


  • conexware

    @binkley:

    True, but it’s unlikely that the same problem would happen on all three (four, counting Terry’s computer) different computers. Also, I’ve run memtest86 on two of these machines within the past 6 months and it didn’t find any problems.

    We are going to test it out and let you know.

    thanks for the great report!



  • Excellent! I look forward to trying out a new version. I’ll remember to check the forums at least every few days.



  • Any news on this bug? I see it’s still in the new version released today.


  • conexware

    I am not sure if this is already fixed in 9.5, I will check it out. No work was done on 7z in 9.25 minor release done today, but 9.5 should be out fairly soon….

    thanks,



  • Just tidying up-
    This is fixed in PA 9.5 (betas).


Locked
 

1
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy