Problems with (de)compression when minimised to tray ?



  • A couple of times in the past I’ve minimised to the tray during a (de)compression operation and I’m sure the operation never completed. I’ve never reported this problem before because I normally don’t minimise the PA progress dialog (and I’ve been too busy to test it:o).

    Has anyone else experienced this problem ?

    PS. I will check again, but maybe it’s worth checking/testing for 9.5.



  • yes i have found this but thought it was jsut my computer



  • :rolleyes: It has actually happened to me on three separate occasions. I also thought that it was just my computer and not PA. But now……



  • Does the format used have an impact?
    I’ve just tried compressing some avi files (350MB) with both 7z and CAB - both completed OK.



  • I was using ZIP when happened to me. Haven’t tested with other formats.



  • Completed OK with ZIP for me when compressing a single file.

    See http://www.powerarchiver.com/forums/showthread.php?p=3248#post3248

    Also worked for BH - hi Charles :p )



  • Once in a while it will hang and not complete when I’m compressing multiple files with cab or 7-zip, but it does not happen every time. I don’t remember it happening with BH, but I’ll test that again later……



  • As Charles says, it doesn’t happen all the time.

    One other problem is that the tray icon is blank when first minimized, as shown by the first attached image.

    After the progress had been updated (showed 56%), the tray icon was half drawn, as shown by the second attached image.

    When the operation completed, the tray icon was updated and correctly drawn.

    Related to the other problem with the tooltip percentage staying at 0%, it appears that it is not updated frequently enough. I say this because during a long operation, the percentage was only updated once (ie. 56%)

    EDIT: On a different note regarding this forum - How come attached images are not displayed in thread if you attach more than one image ?
    attachment_p_3253_0_pa_tray_icon_not_drawn.png
    attachment_p_3253_1_pa_tray_icon_half_drawn.png



  • @deipotent:

    One other problem is that the tray icon is blank when first minimized, … After the progress had been updated (showed 56%), the tray icon was half drawn…
    When the operation completed, the tray icon was updated and correctly drawn.

    I don’t think this is a problem. To me the filling of the tray icon with colour is a graphical representation of the progress - cute :p

    The tooltip appears to be updated for each format EXCEPT zip.
    This is a “simple” bug… the 7Zip works and that is by far the slowest format which returns control to PA for “progress update”.



  • @TBGBe:

    I don’t think this is a problem. To me the filling of the tray icon with colour is a graphical representation of the progress - cute :p

    I hadn’t thought of it like that 😃

    @TBGBe:

    The tooltip appears to be updated for each format EXCEPT zip.
    This is a “simple” bug… the 7Zip works and that is by far the slowest format which returns control to PA for “progress update”.

    In my example I was compressing to ZIP format, although the tooltip only updated once.



  • @deipotent:

    In my example I was compressing to ZIP format, although the tooltip only updated once.

    Yes, that is Klumy’s thread
    See http://www.powerarchiver.com/forums…p=3248#post3248


  • conexware

    So does it actually not work sometimes? It never happened to me so if it doesnt work let me know.

    As to the icon, yes - it draws as progress bar (partially), and % is also same as in progress bar, that includes zip (which is based on number of files and not actual bytes being compressed).

    thanks



  • Re. my original point, it does work sometimes, but occassionally the (de)compression will not complete when minimised to tray. I haven’t managed reproducible steps yet though.

    I would recommend checking the code.


  • conexware

    @deipotent:

    Re. my original point, it does work sometimes, but occassionally the (de)compression will not complete when minimised to tray. I haven’t managed reproducible steps yet though.

    I would recommend checking the code.

    Is it compression or uncompression? Zip or other formats as well? Most of these things are completly unrelated, so it has to be something specific. If it is compression, what happens with the file being compressed?

    thanks,



  • It was compression to the ZIP format. All that happened was that the compression operation stoppped and the archive was intact, but incomplete.

    I will do some more tests to see if I can reproduce and get back to you with more info.



  • @spwolf:

    As to the icon, yes - it draws as progress bar (partially), and % is also same as in progress bar, that includes zip (which is based on number of files and not actual bytes being compressed).

    But in Klumy’s thread
    http://www.powerarchiver.com/forums…p=3248#post3248

    The tray icon is “filling up” (even for single file compression) whereas the tooltip always shows 0% 😕

    Here it is off topic so we should follow up on that thread (different “problem”).


  • conexware

    @TBGBe:

    But in Klumy’s thread
    http://www.powerarchiver.com/forums…p=3248#post3248

    The tray icon is “filling up” (even for single file compression) whereas the tooltip always shows 0% 😕

    Here it is off topic so we should follow up on that thread (different “problem”).

    Yes, i noticed that later on - i thought it was zip thing that he was talking about. Will check it out.

    thanks,


 

6
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy