It's impossible to keep the "Use Deflate64 compression" option un-checked



  • My OS: Windows XP Home Edition, SP3
    The version number and date of the program: PowerArchiver 2019 Standard 19.00.47 (05/2019)

    How to reproduce the problem

    Open the program.
    Go to “Configuration” under Options in the menu. Click on the “Compression Profiles”.
    Select the “ShellExt: ZIP Default” from the list, make sure the “Use Deflate64 compression” option is un-checked and then click OK.
    Exit from the PowerArchiver.
    Open Microsoft® Explorer and select the files you want to compress.
    Click the right mouse button to display the pop-up menu.
    Click on “Compress To Filename.zip”.
    After you zip it unzip using the Windows Explorer. To unzip it, open the zipped folder, then select Extract All, and then follow the instructions.
    You will receive an error message that says that was used the “Use Deflate64 compression” option.

    2019-05-16_12-20-18.png

    … Michael


  • conexware

    Hi @Michael72
    Thanks for the info. Seems fine on a W10 test machine but we will test this on an XP machine today and report the results and log it in as necessary. thanks very much for letting us know!


  • conexware

    Hi @Michael72
    Is this reproducible for you on all files or a specific zip file?

    I have been trying to reproduce it by Windows extracts it OK for me on an XP machine. Opening the Zip in Windows Explorer, then going to File>Extract All works fine. Extracted the files without error

    Also, was the account you experienced this issue on an admin or guest account?



  • @Mili said in It's impossible to keep the "Use Deflate64 compression" option un-checked:

    Is this reproducible for you on all files or a specific zip file?
    I have been trying to reproduce it by Windows extracts it OK for me on an XP machine. Opening the Zip in Windows Explorer, then going to File>Extract All works fine. Extracted the files without error
    Also, was the account you experienced this issue on an admin or guest account?

    I missed an important detail. In the settings you also need to set the Compression option. The problem is reproduced, if for this option set the value to Extreme or Ultra (memory req.)
    See screen capture:

    2019-05-21_20-38-08.png


  • conexware

    thanks for the updated information @Michael72
    Yes, any time Extreme method is used, it is unrecognized by windows explorer extractor on xp when extracting.
    We’ve logged it in, let’s see what can be done.


Log in to reply
 

  • 7
  • 2
  • 11
  • 11
  • 11
  • 4
  • 6
  • 4