FIPS



  • activating FIPS by following the requester of the latest version .39 caused me a lot of trouble, because the culprit was not obvious

    an extensions for ms visual studio was not prepared for FIPS and refused compiling and building

    implications
    blogs.msdn.microsoft

    support.microsoft


  • conexware

    @qrti said in FIPS:

    activating FIPS by following the requester of the latest version .39 caused me a lot of trouble, because the culprit was not obvious

    an extensions for ms visual studio was not prepared for FIPS and refused compiling and building

    implications
    blogs.msdn.microsoft

    support.microsoft

    FIPS is meant to be activated only by users who have legal requirement to use FIPS, it is not recommended for anyone else.
    What can we do to improve this process?



  • currently the decision to use FIPS is very prominent at every start of the program until you say yes, it should be reduced to a check mark in settings


  • conexware

    @qrti said in FIPS:

    currently the decision to use FIPS is very prominent at every start of the program until you say yes, it should be reduced to a check mark in settings

    @Mili will check that out, it should never be in On or Forced mode by default… just Auto, which depends on your system setting.


  • conexware

    there is a setting in the Configuration menu that allows you set FIPS to ON, that turns on FIPS in PowerArchiver. The following confirmation dialog is confirms the enabling of FIPS in the Windows settings.
    In my test, it appeared once, after clicking Yes, it did not appear anymore.
    Is it continuously appearing for you?
    Let us know, we’ll give it a thorough check.

    Thanks!


  • conexware

    @Mili said in FIPS:

    there is a setting in the Configuration menu that allows you set FIPS to ON, that turns on FIPS in PowerArchiver. The following confirmation dialog is confirms the enabling of FIPS in the Windows settings.
    In my test, it appeared once, after clicking Yes, it did not appear anymore.
    Is it continuously appearing for you?
    Let us know, we’ll give it a thorough check.

    Thanks!

    it should never appear unless someone changed fips setting to ON… by default that should never appear, so we have to make sure it doesnt appear by default.

    It is possible that someone left FIPS setting on in previous version of PA though.


  • conexware

    @spwolf said in FIPS:

    @Mili said in FIPS:

    there is a setting in the Configuration menu that allows you set FIPS to ON, that turns on FIPS in PowerArchiver. The following confirmation dialog is confirms the enabling of FIPS in the Windows settings.
    In my test, it appeared once, after clicking Yes, it did not appear anymore.
    Is it continuously appearing for you?
    Let us know, we’ll give it a thorough check.

    Thanks!

    it should never appear unless someone changed fips setting to ON… by default that should never appear, so we have to make sure it doesnt appear by default.

    It is possible that someone left FIPS setting on in previous version of PA though.

    checked, with the default setting on, no confirmation dialog appears. When changed to On, the confirmation dialog appeared once.
    Will wait on @qrti 's details and settings to test the same and make sure it works as intended.



  • I never touched a FIPS setting, I even don’t know where to find it, the requester popped up at every start of version .39 until I said yes, after that PA started without the requester


  • conexware

    Thanks for the information @qrti
    Could you please go to the Options tab and click the Set Defaults button.
    That will set PowerArchiver to the default settings, does it occur then, after the default settings have been set?

    Thanks for your help!



    • 2019 .39 was not installed anymore
    • so I uninstalled the current 2018 version
    • and did a fresh installation of 2019 .39 version
    • no FIPS requester

    maybe the FIPS message was a settings conflict with the previous .33 version, I did an update from .33 to .39 and no fresh installation at that time



  • I’m running 19.00.39, which was updated a couple of days ago, and since when I get the “Enable FIPS” popup. It’s impossible to turn it off in the AI setting screen, so I followed the recommendation to reset to Defaults which seems to fix it i.e. the popup doesn’t appear.

    As far as I can judge, I have no need at all for FIPS to be enabled on this machine, and there seem to be a number of recommendations against enabling it on Windows.

    I have my PA set up in a particular way (incorporating some of the points/features that were problematic in the test phase), and I’d hate to have to keep resetting it from defaults to my preferences.

    Out of interest, I’d like to know this. I reset to defaults, then rejig my configuration to suit me, and then save the settings as the reg. entry. Would importing these settings always get me back to my configuration but minus FIPS and associated popup?


  • conexware

    @PA_Fan said in FIPS:

    I’m running 19.00.39, which was updated a couple of days ago, and since when I get the “Enable FIPS” popup. It’s impossible to turn it off in the AI setting screen, so I followed the recommendation to reset to Defaults which seems to fix it i.e. the popup doesn’t appear.

    As far as I can judge, I have no need at all for FIPS to be enabled on this machine, and there seem to be a number of recommendations against enabling it on Windows.

    I have my PA set up in a particular way (incorporating some of the points/features that were problematic in the test phase), and I’d hate to have to keep resetting it from defaults to my preferences.

    Out of interest, I’d like to know this. I reset to defaults, then rejig my configuration to suit me, and then save the settings as the reg. entry. Would importing these settings always get me back to my configuration but minus FIPS and associated popup?

    How do you mean it is impossible to turn it off? There is an Off setting there.

    And yes, saving your HKCU settings and restoring them will always bring your full settings.

    From next release, we will show warning only when in Enforced mode for FIPS.


  • conexware

    Should work better now in version .41, please let us know and thanks for the report
    https://powerarchiver.cachefly.net/2019/powarc190041.exe


Log in to reply
 

  • 3
  • 6
  • 17
  • 1
  • 3
  • 8
  • 5
  • 25