Not prompting for Password



  • I created an encrypted 7z archive out of a few old Word docs and had it move them into the archive and then delete the originals when done. That part worked OK but I’m having a problem that it is NOT asking for the password when I open the archive. There is nothing saved for it in Password Manager. I even copied that 7z archive to a NAS drive and opened it with a different PA install on another computer and it also didn’t ask for a password…

    Obviously that is a problem. Any idea why this is happening?

    Thanks


  • conexware

    @bigdog is the archive actually encrypted? Can you extract the files without password? Thanks!



  • I tried it again and it does seem to prompt before actually extracting the files which is some relief. However it does show the filenames in the archive without any password entered which it should not be doing if they filenames are encrypted.


  • conexware

    @bigdog said in Not prompting for Password:

    I tried it again and it does seem to prompt before actually extracting the files which is some relief. However it does show the filenames in the archive without any password entered which it should not be doing if they filenames are encrypted.

    Filename encryption is optional… so try it again and make sure it is checked in Add window?

    Also, .pa format is a bit more secure than 7z, you can also try that too - both better security and compression are the benefits.

    thanks!



  • Yep it was checked (tried it twice) and still didn’t encrypt the filenames when I moved them into the 7z archive. I know pa is supposed to be more secure but for these particular files needed to use a format that was more universal so went with 7z.

    Anyway if you could take a look at why it is not encrypting the file names when moving files (and deleting originals if that makes a difference) into a 7z archive, I’d appreciate it.

    Thanks


  • conexware

    @bigdog said in Not prompting for Password:

    Yep it was checked (tried it twice) and still didn’t encrypt the filenames when I moved them into the 7z archive. I know pa is supposed to be more secure but for these particular files needed to use a format that was more universal so went with 7z.

    Anyway if you could take a look at why it is not encrypting the file names when moving files (and deleting originals if that makes a difference) into a 7z archive, I’d appreciate it.

    Thanks

    where are you doing it from? When I first replied, I checked before via compress + options in shell extensions and it has worked correctly. There are many different ways you can do it in PA, so just making sure I tried the same as you did.

    thank you!



  • I select the files and then right click PowerArchiver->Encrypt and then it opens PA where I can select options 0_1535658730921_PA options.jpg

    It then moves them to the 7z archive and deletes the originals (like it should). I go to open that newly created 7z archive and it opens, displaying the filenames without prompting for a password. As you can see in the previous screenshot, encrypt filenames is checked but here is what it shows when I open it. 0_1535658885028_pa files list.jpg


  • conexware

    thanks, got it now… you can use shell extensions in between the fix, they properly hide the filename (compress + options instead of encrypt, and just select options there).


 

2
Online

9.8k
Users

6.0k
Topics

36.7k
Posts