18.00.48 keeps opening text file in notepad!!


  • Alpha Testers

    I have had PA 18 set up to view files in Notepad++ for some time and it has worked fairly recently but the current 18.00.48 version always uses Windows Notepad which does not view Linux text files properly.

    If I try to set it back to using Notepad++ the setting is instantly set back to Windows Notepad.


  • conexware

    @brian-gregory someone wrote in something similar few days ago, but @Mili wrote it in so I did not investigate. How exactly are you setting up Notepad++ in PA?

    I just used Modern> Right click on file in file list, and Open, Open With…, and View all worked fine when I tried a text file in .zip archive and different options. Granted, N++ is my default associated .txt editor in Windows, but Open with… also worked and so did View when selecting other options.

    thanks!


  • Alpha Testers

    Open archive. Right click on some kind of text file (It was .cpp in my case) choose “View…” select “Viewer:” notice that it’s mysteriously set to use Windows Notepad, change it back to Notepad++ as I usually have it. Click “View” button, file opens in Windows Notepad. Angrily exit from notepad and notice that “Viewer:” has been set back to Windows Notepad.


  • Alpha Testers

    @brian-gregory
    Did you change the viewer in PA’s Settings area? Mine was still set to Notepad++ and I’m now using AkelPad


  • conexware

    Yes, same issue as reported earlier by @drteeth and it has been logged in for fixing.
    Added this thread to the report so we may post the fix once ready.

    thanks very much for letting us know @Brian-Gregory !


  • conexware

    @brian-gregory you can set it here and it seems like it sticks:

    0_1524501329249_977be5ed-5e16-41ab-918a-00015ea9a04d-image.png

    Also, what about using Open With menu instead of View? It is based on Extension, so you can set different options based on extension of the file there.

    thanks!


  • conexware

    I’ve also tested the Open filename.cpp option as well(the one at the very top of the right click menu) and that works, opens with the associated application.
    That could be a workaround until we update the view option.


  • Alpha Testers

    @ckit Thanks, I’d forgotten about that setting. Changing that one to Notepad++ does allow me to use Notepad++ as the viewer.

    But why the two possible ways of choosing the viewer?

    Maybe the one in Settings should be the default but the one in the View dialog is completely non functional at present!


 

4
Online

9.8k
Users

6.0k
Topics

36.7k
Posts