Cloud Folders as Upload Target Folders-not working?



  • PA 2018 - 18.00.32 Win7

    This seems to be a continuation of a problem I experienced in PA 2017.

    I have OneDrive, Dropbox and Googledrive clouds. In each of the clouds, there are a number of subfolders; for example <Googledrive>/TAX, <Googledrive>/BILLS and so forth.

    When I run a backup via a .pbs script, I want the archive to be written into the cloud subfolder I’ve specified when creating the script (see screenshot).

    In this case, I have defined my Google cloud target as “TAX”, but whatever I do, the archive is always uploaded into the root folder of the cloud drive, so I have the folders TAX, BILLS and so forth listed in My Drive, with the uploaded archive as a solitary file in the root folder.

    I have tried defining the cloud folder TAX with forward slashes, backslashes, on it’s own and several other ways, but it makes no difference; the archive always ends up outside its targeted folder.

    Of course, I can get around this by getting the pbs script to write the archives into the local cloud My Computer folders; in this case my main My Documents Archives folder plus the 2 additional cloud upload folders e.g. C:\Users\Peter\Google Drive\My Stuff . I then do an upload to cloud via the Google, Onedrive or other upload utility, which sweeps up any other files I’ve updated in the upload source folders as well as my PA archive. The PA archive will then arrive in the correct cloud target folder.

    It would be nice if the pbs script would upload the archive direct into the named cloud folder, as I need the upload automated somehow.

    If I open the archive locally, and then use File>Clouds>Upload to Clouds >Googledrive and then select the TAX folder interactively, it works fine.
    0_1519902810309_Clouds.JPG


  • Alpha Testers

    I created a Test folder in dropbox and then configured in PA the Destination Directory as this :
    0_1519949538119_31e08473-faa1-4c70-9406-e7ec13d125a4-image.png
    (only the name of the folder without slashes)

    I runned the backup script and the ‘zip’ file is posted directly in my dropbox Test folder.
    0_1519949800589_d0bb70e2-8e73-462e-b34c-7d24e4ed6c42-image.png

    When you want to create a subfolder in the folder do not use ‘spaces’.
    Underscores work !
    0_1519951041887_24ee1e53-868a-476d-a195-c35dc4b7df7b-image.png

    0_1519951140185_6bbbe39c-c5f0-456c-9a62-bba19931c3da-image.png
    I hope this solves your problem.



  • Thanks for the responses.

    I had tried using the folder name without slashes, for Googledrive. It still piles up several copies of the uploaded archive in the root folder. I presume that it doesn’t overwrite them as they have the same name and size, but different dates and times.

    I’ve tried the same thing in Dropbox, but all I get is a “Not Responding” message. However, if I use the desktop Dropbox uploader, the file is successfully uploaded from my local \User\Dropbox folder.

    Using OneDrive, it seems to start working but exits within seconds without uploading anything to anywhere in the OD cloud. Again, the desktop OD uploader works fine.

    I have deleted the three Clouds in PA, cleared credentials and set them up anew, but this doesn’t make any difference.

    So, to summarise:-
    Google - uploads, but only to root of cloud folders
    Dropbox - errors out
    OneDrive - runs, exits, does nothing

    I have no idea why this should be, but I’ll try odd things like running PA with Admin privileges to see if that alters anything. However, I suspect that a direct upload to clouds from PA isn’t going to work for me, for reasons I cannot fathom.

    I should say that although I haven’t tried all three (just ODrive), I can upload the file interactively from PA archive open to cloud upload. It’s just running these via pbs which causes problems. I have looked at the pbs for GoogleDrive and it has my target cloud folder correctly given there.


  • Alpha Testers

    @pa_fan hereby my actual status 😞
    dropbox : works perfect and .pbs scripts UL files to defined folders
    google : uploads, only to root
    ondrive : uploads, only to root
    what the hell…


  • conexware

    thanks for the input all!

    We’ll check this out and see what’s going to figure how to improve it. Any further details are welcome.

    Thanks!


  • Alpha Testers

    @mili Google’s direct sync folder works perfect to overcome the root filing problem. It’s a plan B but finally I have my PA backups in the google cloud, where I want them :-).
    For onedrive : microsoft helpdesk referred me to PA helpdesk to solve the root cloud problem, not their problem as a third part is involved…


 

4
Online

9.8k
Users

6.0k
Topics

36.7k
Posts