PA crashes when using 1st char to select file



  • With an archive open, pressing the key matching the first file name character to jump to the first matching file, causes a PowerArchiver crash.

    i.e. if a file in the archive is “THEFILE.TXT” (first starting in T) then pressing the letter ‘T’ sets the focus in the list to that file but immediately puts up a dialogue box with “PowerArchiver 2017 has stopped working” . This is a Windows dialogue and says: “Windows will close the program …”.
    Happens in large and small archives. Checked in .zip and .rar


  • conexware

    @south37 is this with PA 17.01.04 or earlier release?


  • conexware

    @south37 i assume you are using latest one… can you please send your settings (Options> ) to support at conexware dot com, so we can check with your exact settings.

    We had this reported few versions back, cant reproduce it here right now. Thanks!



  • I have emailed the settings file.

    The version I am using is 17.01.04


  • conexware

    @south37 hm, seems to work fine on my laptop. What OS are you running? Nice settings!



  • Windows 10 64bit Ver 1511 Build 10586.0


  • conexware

    @south37 same here. Lets see if @Mili can reproduce it in the morning. Thanks!



  • The Windows crash log “Report.wer” says:

    Sig[0].Name=Application Name
    Sig[0].Value=POWERARC.EXE
    Sig[1].Name=Application Version
    Sig[1].Value=17.1.4.0
    Sig[2].Name=Application Timestamp
    Sig[2].Value=59d2a005
    Sig[3].Name=Fault Module Name
    Sig[3].Value=ntdll.dll
    Sig[4].Name=Fault Module Version
    Sig[4].Value=10.0.10586.0
    Sig[5].Name=Fault Module Timestamp
    Sig[5].Value=5632d193
    Sig[6].Name=Exception Code
    Sig[6].Value=c0000005 <-- This is an Access Violation I believe
    Sig[7].Name=Exception Offset
    Sig[7].Value=00000000000348ae


  • conexware

    @south37 unfortunately without debugger running, windows log is not useful to us. Once we can reproduce it on development machine, we can usually see exact code causing the issue.


  • conexware

    tried reproducing here as well with the settings, no luck.
    does it occur on one specific file or all files?

    If it’s on a specific file, could you send it please?

    thanks



  • It occurs on all files. I created a small archive with test text files and the error occurs on that as well as on larger archives.
    So it is not the file itself but something else.

    The only clarification I would make is that I initially said that the crash happens immediately after pressing the key. In fact it takes about a second or two before the crash occurs. After pressing the key to jump to the file, I can still move up or down in the file list with the arrow keys before the crash occurs. If I press the arrow keys quickly enough the crash is delayed quite a while and occasionally does not occur at all. But I can’t use the 1st char jump method to select another file before the crash occurs.


  • conexware

    @south37 Can you try exporting HKCU\Software\PowerArchiverInt and sending it over please? Then try using Options> Reset to Default and see if this issue still happens for you.

    You can recover your settings by running that reg of course.

    Maybe some setting that causes issue is not exported via Options.

    much appreciated!



  • I have exported the registry keys and emailed them.

    After resetting to installation defaults, the problem is still there. PA crashes still.



  • Hi,

    I encounter the same issue 😢

    • On my pro laptop (Windows 7) or my personnal desktop ( Windows 10 Redstone 2).
    • I’m admin on both of computers;
    • Normally registered user for both Windows and PA;
    • Problem with RAR ou ZIP compression format, not seems to be linked with file, but HCI only;
    • Same issue if preview panel is opened or not;
    • Windows settings on my desktop PC : desktop folder is not on default folder.

    My way to reproduce :

    1. I open a RAR file [with one folder (and many things in it)];
      The folder is beggining with digit 1;
    2. I just click on the key ‘1’ and after 1 or 2 seconds, Windows pop-up with failure

    What explains south37 is exactly what i have too : if i use a zip file with many entries, i can type one letter, and PA jump to the correct item, and i can still move till app crashes.

    .
    .
    Using Procmon from sysinternals.com, i saw a result ‘Invalid PARAMETER’ trying to read Data/list directory.
    Last event is making a QueryOpen on ‘PowerArchiver 2017.lnk’ on my desktop with a Result Name not found. (i d’on’t want/checked th desktop shortcut).

    I sent an e-mail with procmon log file (sorry, french info in zip)

    Maybe with this it’s better to fund the issue ?


  • conexware

    thanks very much for sending over the information @cporeaux

    We still have not been able to reproduce the issue and it is essential that we reproduce it.
    Could you please send us a sample file that reproduces the error for you?

    We hope to then reproduce it here so we can log it in for fixing.

    Thanks!



  • Hi,

    So it should be linked with the environment and not the compressed file only ?
    I’ll send you a very short file, the problem does occur with it also.
    If you have any other test to do or if you have a version to have more log for you, still no pb.

    Regards


  • conexware

    @cporeaux we were able to reproduce this issue on Win7 x64 image… but not on others, very interesting. Hopefully we can fix it soon enough.

    thanks again!


  • conexware

    @cporeaux Can you please check with following release and let us know if the problem is still there:

    New version: PowerArchiver 2018 18.00.23 - BETA 1
    Download: http://dl.powerarchiver.com/2018/powarc180023.exe

    thanks!



  • Just installed and tested the new beta on my desktop machine and the crash still occurs.


  • conexware

    @south37 said in PA crashes when using 1st char to select file:

    Just installed and tested the new beta on my desktop machine and the crash still occurs.

    thanks for letting us know… i was aware that nothing specifically was done for this, but lets see in next releases. How does 2018 feel otherwise? Thanks.


 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts