Compress to ZIP ignores option "Use normal relative path". (when using PA Queue)



  • In PA 2016 was OK, but in PA 2017 is option “Option / Configuration / Miscellaneous / General / Use normal relative path” ignored for compressing ZIP archives.
    Actually im using 2017.01.04 x64 on Win10 Pro.

    My folder/file structure to compress:
    firstDir/
    firstDir/secondFile1
    firstDir/secondFile2
    firstDir/secondFile3

    When i check that option (ON) and compress “firstDir”, then i expect that structure in archive include root “firstDir”:
    firstDir/
    firstDir/secondFile1
    firstDir/secondFile2
    firstDir/secondFile3
    I tried ZIP, 7Z and PA formats, and all was good, as i expected.

    But when i uncheck that option (OFF) and try to compress “firstDir”, then i expect structure without root “firstDir”. I want only “second*” and deeper levels.
    secondFile1
    secondFile2
    secondFile3
    7Z and PA formats are OK, but ZIP ignores that option and compress data with “firstDir”. Result archive is same as if option was checked (ON).

    I guess its a bug in ZIP compression. Folder/file structure should be same for all formats.

    Can someone verify this and tell me if im right or wrong? Thanks.


  • conexware

    @dogm @Mili will check it out, thanks a lot for detailed report!


  • Alpha Testers

    Seems to work right to me.
    With “Use Normal Relative Path” unchecked if I right click folder1 and choose compress to folder1.zip, the files in folder are added to the archive without “folder1” before them.
    Am I misunderstanding?
    (I’m using PA 17.01.04 on WIndows 7 x64)


  • conexware

    @brian-gregory @DogM maybe the difference is what you use to add files - main add window, shell, etc?


  • conexware

    How are you compressing the Zip?
    Right click on root folder and “Compress to Zip” or another method?

    We will test using the same method and compare folder structures inside to make sure it’s working properly.

    Thanks for the report



  • I try it again and problem is, that im using PA queue, with “Always use Queue” ON.
    When i disable queue (“Always use Queue” OFF), result is same as you tested, that means OK.
    With queue enabled (“Always use Queue” ON), right click (in Total Commander, Windows Explorer,…) on folder “firstDir” and use “Compress to firstDir.zip”, then archive contains that folder and it should not be.
    Sorry for not-so-exact description before.


  • conexware

    @dogm ah, it is Queue…good to know. I believe it will be reworked completely for PA 2018, lets see how that works then.


  • conexware

    @dogm I have added this bug for to the list of things for Queue in PA 2018.


 

7
Online

9.8k
Users

6.0k
Topics

36.8k
Posts