Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Files blocked due to emergency stop on compression


  • Alpha Testers

    scenario : started explorer shell ‘compress xxxx to .pa’. / interrupted the process (forced) and started ‘compress xxxx to .zip’.
    result : Impossible to delete the created .temp and partial .pa file…
    Checked MS Task manager : no trace of PA.
    Started PA and closed : still same result…

    0_1503646910025_c877aedd-d495-4b8d-9720-0af0f7e19010-image.png

    Conflict due to forced interrupt caused by user or no foreseen prog scenario by PA ?

    remark : through PA Dashboard the interruption caused no problems. Stopped the cancelling (does it works?) and forced with task manager the exit of PA and the files can be deleted.


  • conexware

    hmmmm, tried it here and cancelling the PA file creation cancels it immediately and the PA archive that was being created disappears(properly)

    Tried it on a larger file as well and same behavior happened.

    How large is the file you are compressing and are you using version .92?

    Thanks!


  • Alpha Testers

    @mili One detail I forgot : I also interrupted the Cancel process of PA !!
    As nothing seems to happen in cancel process (only speed decrease), I closed the process using the “X” MS standard.
    0_1503664877309_cfc8499e-78ea-4c11-bf36-9f62f6f46e8a-image.png
    (on .92 - x86 :-( .
    (76 mb - 58% completed - after cancel proc > 4 minutes, closed by X process)
    The compress happens at a logical speed for my x86 but the Cancel beats all time records, reason why I forced it to stop… can you simulate this on your x86 machine ?


  • conexware

    hey, thanks for the details! Just tried this on an x86 machine.
    Compressing 2 files, together at 365mbs, into a PA format, click Cancel at 60% of compression and then click NO at confirmation screen and the progress window disappears in a few seconds and the PA file is deleted immediately. And this is a rather slow x86 machne.

    Is there Anti Virus software that could be slowing it down and/or throwing the “File in use” error?


  • Alpha Testers

    @mili aaah, I simulated your simulation. Indeed with a compress interrupt of ‘FILES’ no problem. Everything disappears indeed after a few seconds.
    But can you select a FOLDER (containing subfolders) : curious about your results then…


  • conexware

    @pirrbe if you cancel via task manager, then file could stay locked, depending on luck… because you forced quit PA.exe, it can not release the file. I assume there is no powerarc.exe left in task manager? Then restart would “solve” the issue.

    Mili will try reproducing the folder cancel issue.

    thanks!


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.