Please Notice: Welcome to our new forums! You will need to reset your password in order to login. Thank you - PA Team!

Tricky : how to create an archive .pa with a 'no error' report but which is corrupted...


  • Alpha Testers

    I tested this case several times and got same results. If you run a batch for creating a .pa archive and run that batch a second time in the same session, you have a corrupted archive. Problem is that the created test on errors creates a ‘no error’ report… dangerous if you delete original files based on such a report.

    • open PA dashboard / select ‘BACKUP’ / select 'NEW’
      Then the usual parameters…
      For compression I used this parameters :
      pa compression/use current folder as temp /test created archive after backup
      For logs : log to file
      then ‘FINAL’ with ‘set as default’ and 'do backup’
      then 'FINISH’
      This is the log.txt file :
      0_1497045946847_fd0c59a8-c9d5-44b8-a988-e8e6a3d5d047-image.png
      The archive is perfect and can be opened in ARCHIVE / Open.
      0_1497046113567_932efa3c-3cc7-4b62-9434-876be297e0e6-image.png
      And now this is tricky :
      In the dashboard go to BACKUP. Select the same .PBS batch and press in the upper command bar ‘RUN’ and you got a new ‘no error’ check
      0_1497046436302_ae50159b-c972-4222-8910-8de0f3510a75-image.png
      Now go back to ARCHIVE / open / and select the just created .pa archive and try to open it …
      This is the result :
      0_1497046639263_b025b65c-4d82-4a4e-a075-4938816929b5-image.png
      I guess something is going wrong with a pointer/stack in the program or the program doesn’t refresh memory and consider the archive in use… that perfect no-error report is a mystery …

  • conexware

    @pirrbe i think it is not locked because there are multiple threads writing into it (depending on files could be 10-15) at the same time… but as to the no error, we will be checking it next build. Thank you!


  • Alpha Testers

    @spwolf Just for the record : this morning, from a cold system restart, I tried to open that file. No way, the file is corrupted such as… Yesterday, in that same session, after the corruption report, I tried to rebuild the archive from that .pbs but from another way. Result : the whole program stopped/blocked with a classic windows OS error…


  • conexware

    @pirrbe ah, so Backup wasnt running together, it was one after another?


  • conexware

    @pirrbe so after restart, same file works fine?


  • conexware

    @pirrbe can you send us that pbs to support please, so we can use same settings as you. Thanks!


  • Alpha Testers

    @spwolf In my first post I mentioned ‘same session’. After the first archive creation with .pa compression , I executed the same .pbs again, staying in the same open dasboard ! And this caused a corrupted archive. A cold restart of the system resulted the same error message by opening that archive. Or the file is not physical corrupted but no more accessible (?). Ok, I will send you the .pbs file and the test file I wanted to archive. (just a commercial pdf presentation of a new car). Np.


  • conexware

    @pirrbe said in Tricky : how to create an archive .pa with a 'no error' report but which is corrupted...:

    @spwolf In my first post I mentioned ‘same session’. After the first archive creation with .pa compression , I executed the same .pbs again, staying in the same open dasboard ! And this caused a corrupted archive. A cold restart of the system resulted the same error message by opening that archive. Or the file is not physical corrupted but no more accessible (?). Ok, I will send you the .pbs file and the test file I wanted to archive. (just a commercial pdf presentation of a new car). Np.

    thanks pirrbe for explaining it to me… can you reproduce this again or was it one time thing?


  • Alpha Testers

    @spwolf I can produce it any time… But not with a .zip. I will retest it, but with a .pa compression it is each time bingo.


  • Alpha Testers

    Confirmed using PA archive but I didn’t bother with the Logging or Setting as Default


  • Alpha Testers

    @pirrbe **A zip archive ** will not suffer and stays intact. All .pbs batches wih a .pa compression are destructive, once you run the batch twice in a same session, the archive is no more accesible…


  • conexware

    @pirrbe thanks to those files i discovered that it creates .7z archive 2nd time around, hence it cant be opened as .pa… it works if you rename it to .7z… seems like something simple in gui that we should be able to fix quickly… thanks a lot!


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.