Issue with advanced option in compression profiles

  • Alpha Testers

    I guess that there is a bug or at least an issue, with default advanced options when compressing using context menu.

    If I go to Context Menu -> PowerArchiver -> Compress with options, you can see I have set the Profile to “Strong”, and Method is set to “Optimize Strong”.

    Compress with options 01

    But if I switch to the tab “Advanced Options”, I see on “Entropy model” the value of “lzma (fast)”, but it should be according to the description “lzmarec (strong)”. Also Analysis limit optimization should be set to 273, Zstd compression to 24, zlib level to 9. Remember that profile is the to Extreme.

    Compress with options 02

  • conexware

    @nikkho yes, so right now, advanced options is only when you set custom compression method, not optimized… with optimized very long codec chains are used with multiple different codecs used for different extensions. Right now we have at least 10+ different compression steps with its own codec chains used to improve compression for specific sets of files.

    But thanks to nudge from you, we are looking into enabling chaning at least main codec params which in this case would be plzma4.


  • conexware

    @nikkho you can now set advanced options for optimized modes, just check the checkbox next to the option:

    Options also preset for your selected strength. Keep in mind that if changing C, set it to 4x dictionary level (C is chunk size for mt thread)


Log in to reply