RAR4 and RAR5 Issue



  • If I choose “Compress with Options” and select the RAR format, I am offered, under Compression Options, “Default RAR4” and “Default RAR5.” It doesn’t matter which option I choose, the compressed file will always be a RAR5. I’m using PA 17.00.68 with WinRAR 5.50 beta 1.


  • conexware

    Thanks very much! logged in



  • I have some additional information.

    I forgot to mention that the created RAR archives are always solid archives, even though this option is not selected in the compression profile for RAR. Again, this assumes WinRAR 5.50 beta 1. The behavior is a little different if using the current official WinRAR release (5.40). But even using version 5.40, PA always creates a solid archive.


  • conexware

    Hi Robert,

    How are you creating the RAR archives?
    I have attempted to reproduce the issue with solid/non solid RAR archives and it seems fine here. Solid and non solid RAR archives were created appropriately.

    Using PA version .69 and Wrar 5.50

    Let us know how you created the archives and we’ll attempt the same process in hopes of reproducing.

    Thanks!



  • Hello, Mili.

    My “Compression Profile” for RAR:

    [https://1drv.ms/i/s!AgVhuW8u-GbEhExfia6CuF-PXlyO](link url)

    If I right-click on a file and choose “Compress to ‘filename.rar’” the resulting file will be a non-solid RAR5. I determine this by opening the file with WinRAR and selecting “Show information” from the Tools menu. If I change the PA compression profile by selecting RAR4 as the default, I still get an RAR5 file.

    OTOH, if I select “Compress with Options” and choose the RAR format, under Compression Options-Method, a drop-down menu seems to offer a choice between RAR5 and RAR4. However, no matter what is selected, I always get a RAR5 solid archive.

    So, bottom line, I can’t get the program to create an RAR4 archive, no matter what I do. Right-clicking and choosing “Compress to ‘filename.rar’” produces a non-solid RAR5. Using Compress with Options produces a solid RAR5 archive.

    I’m using WinRAR here to tell me what kinds of files I get.

    Thanks.


  • conexware

    Thanks again RobertM, we have logged the additional info in and the dev team will check it out.

    we appreciate the details!


  • conexware

    please check now in .70, it should be properly rar4 if chosen:
    https://forums.powerarchiver.com/topic/5747/fast-ring-powerarchiver-2017-17-00-67-68-69-70


  • conexware

    looks good here at first glance, rar4 created properly when selected



  • This is certainly an improvement! 🙂 I can now create RAR4 files. A few observations.

    The “Compression Profile” for RAR doesn’t appear to have any effect. My profile sets RAR5 as the default - and the box to create solid archives is not checked. However, right-clicking on a file and selecting “Compress To ‘filename.rar’” now produces a SOLID RAR4 file. If I instead choose “Compress with Options” I can select either RAR4 or RAR5 and produce the type of file selected, albeit always as a solid archive.

    So the “Compress with Options” procedure now seems to work as I would expect, except for the solid archive issue (which isn’t a huge issue). The other procedure - right-clicking on a file and selecting “Compress To ‘filename.rar’” - seems to be broken, producing only RAR4 files.

    Creating a RAR through the interface (by selecting “New Archive” etc.) produces an RAR5.

    Thanks!


  • conexware

    @RobertM is solid option on possibly in add window? Maybe that adds solid.

    As to the compress to .rar, that has its own compression profile by default. Did you try changing that?

    thanks!


  • conexware

    Hi @RobertM

    I have noticed the same in my tests. Logged in for fixing in the next version
    Thanks a lot for all the help!



  • @spwolf said in RAR4 and RAR5 Issue:

    @RobertM is solid option on possibly in add window? Maybe that adds solid.

    As to the compress to .rar, that has its own compression profile by default. Did you try changing that?

    thanks!

    Hello.

    The only place I’ve found where I can select (or not select) solid archives is in the compression profile. Where else is there an option for this setting? Here is my RAR profile ---->>

    https://1drv.ms/i/s!AgVhuW8u-GbEhExfia6CuF-PXlyO

    I’ve assumed that the compression profile is a global setting, meaning that right-clicking and selecting “Compress to” should produce the type of file configured in the profile. And yes, I’ve played with that setting. It makes no difference. I get a solid RAR4 file, even though my RAR profile specifies RAR5 and solid archives are not selected.

    Thanks!


  • conexware

    Hi @RobertM

    The compression profile section in config relates to usage of formats through shell extensions.
    You can create additional compression profiles which you can use in add dialogs such as the “New archive” add dialog and compress w options. Here is a screenshot for reference;

    0_1494438456850_RAR custom profile.PNG

    the new archive/add dialog has an Options tab at the top where additional options, such as the Solid Archive checkbox, are located. It’s there for every format and .PA format as an Additional Options tab for more settings.

    0_1494438065644_RAR Options.PNG



  • If it had been a snake it would have bit me! Thanks for pointing this out! I missed entirely the Options tab.


  • conexware

    @RobertM said in RAR4 and RAR5 Issue:

    If it had been a snake it would have bit me! Thanks for pointing this out! I missed entirely the Options tab.

    maybe we need to move solid option… and move queue to the options tab.


 

4
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy