SharpShell errors in Win 7 Event Viewer



  • Over the last few days I’ve suddenly started getting a slew of SharpShell “0” errors in the Event Viewer. These all relate to creating icons, mostly creating overlay icons. There is very little information to help with identifying what process is causing this, but by turning on some extra process creation logging, it seems that the errors all occur at the same time as PABACKUP.EXE, SearchProtocolHost.exe and SearchFilterHost.exe.
    Are these in some way related?
    I can upload more information, if required.


  • conexware

    @PA_Fan said in SharpShell errors in Win 7 Event Viewer:

    Over the last few days I’ve suddenly started getting a slew of SharpShell “0” errors in the Event Viewer. These all relate to creating icons, mostly creating overlay icons. There is very little information to help with identifying what process is causing this, but by turning on some extra process creation logging, it seems that the errors all occur at the same time as PABACKUP.EXE, SearchProtocolHost.exe and SearchFilterHost.exe.
    Are these in some way related?
    I can upload more information, if required.

    is something uploading those backups you create? Like dropbox folder for instance? For instance backup could create an zip file, search engine would try to catalogue it and some upload service could create overlay icons for uploading state.


  • conexware

    @PA_Fan do you know what is using sharpshell? Apparently it is SDK for building shell extensions via .NET framework.



  • @spwolf Nothing is running to upload anything, as I have all cloud applications set to run on my command only.

    I’ve tried to isolate this exactly to a particular program, but it’s not easy. The Event Viewer (EV) doesn’t give any clues, and although I have turned on the Security audit process creation/termination via Group Policies, that throws up some information which is ambiguous in determining the culprit.

    Process Monitor logging isn’t helpful until I can work out what to filter for, otherwise the logs are just too enormous.

    I have just cleared all the logs on EV, so that Errors is zero. I then ran PA, looked at an archive, and then ran a pbs script, which ran to end.
    However, the end screen for the script run was as per shot #1, with icons all over the place. This is the “flickering” and distortion I have reported before.
    The EV, previously empty, now shows 15 Sharpshell errors and 1 .NET error, and all time to the running of PABACKUP.EXE.

    This may be coincidence, or not directly connected with PA, but I’m at a loss to see how running PA would provoke the Sharpshell errors, or what else could be running at the same time to do so.2_1485096972044_sharp-#3.JPG 1_1485096972044_sharp-#2.JPG 0_1485096972043_sharp-#1.JPG

    I also have a problem where the opening screen on PA shows multiple panels, as per shot #2. If I then select an archive to open, it will appear in one of the panes - shot #3. PA is also slow to close, presumably because of the number of panes now in the screen.

    I should add that I haven’t had these Sharpshell errors before on this system (i.e. years), and they seem to have arisen since 2017 was installed. I have certainly not had the icon/screen problems with PA 2016.

    PS #3 is top shot, #2 middle, #1 bottom.


  • conexware

    @PA_Fan sharpshell is .net library for shell… so what programs are running shell, it does not have to be a .net program though? If you look and download shellexview, you can disable individual shell extensions and figure it out that way. That should help with troubleshooting:
    http://www.nirsoft.net/utils/shexview.html

    Can you please post the issue with screens into separate threads, pretty please? That way we can track it separately and fix it next week. Thats very much on us, so we would like to fix it asap. Thank you very much!



  • @spwolf
    Certainly I will post into separate thread. I included them here because the Sharpshell errors seem connected with icon management and creation, and, given that the screen problem seems to be icon-connected (at least in some way), I wasn’t sure if there might be a connection.


  • conexware

    @PA_Fan said in SharpShell errors in Win 7 Event Viewer:

    @spwolf
    Certainly I will post into separate thread. I included them here because the Sharpshell errors seem connected with icon management and creation, and, given that the screen problem seems to be icon-connected (at least in some way), I wasn’t sure if there might be a connection.

    with link to shellexview, you will be able to manually disable various different shell extensions, and you will certainly find the issue since you wont have that many non-microsoft ones.

    as to the screen issue, it is a backup bug, it doesnt have anything to do with icons in any way, it is just that backup writes wrong values in PA registry once completed and causes issues…


 

Suggested Topics

4
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy