Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

File Rename in ZIP archive is not working



  • Prerequisites:

    1. Use the latest version of PowerArchiver Toolbox.

    Steps:

    1. Open some ZIP file containing two or more files.
    2. Select to rename one of the files contained in the ZIP file.
    3. Provide a new name and press OK in the rename file dialog.
    4. Notice how nothing seems to happen.

  • conexware

    thanks, checking it out!


  • conexware

    Tested here and rename worked.
    Tested by right clicking a file inside archive and then Rename
    or selecting a file and then Rename from the Action menu.

    Please send us a sample archive that reproduced it on your machine along with your settings(in a Cab file) to support at conexware dot com and we will attempt to reproduce it that way.

    thanks!



  • I forgot to mention something very important, Namely, the name of file I tried to rename was very, very long, over the NTFS file name (path) limit of 250 chars.

    Maybe that is the problem?

    Knowing that the file name is exceedingly long, I tried to rename it.

    Does this help?


  • conexware

    Thanks for the info.

    Here I have a 263 character filename to which I added characters to rename and it worked. Also removed characters to a shorter filename, also worked.

    Maybe we can give it a try with your sample file and settings as described in my previous post. Hopefully we’ll be able to reproduce it then.

    thanks!
    attachment_p_35083_0_long-filename-rename.png


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.