Multiple steps to get better compression



  • I’m using the latest build of PowerArchiver 2016 16.00.69

    I have gone through the Compression Profiles settings and set it up just the way I want it, regarding 7-zip format, but others also.

    I now right click and select “Compress to xxxxx.7z” for it to compress with all options I have already set up for 7-zip, I assume.

    However, the file size I get using the above method is ALWAYS bigger (i.e.: compression isn’t as good), as if I right click and select “Compress to 7-Zip + Options” and then just click Add.

    PS: The settings on the “Compress to 7-Zip + Options” are the same as I have already set up in the Compression Profiles pages.

    So why do I have to perform this multiple click process to get the best compression, when just right clicking and selecting straight to 7-Zip compression should get me the same compression as the multiple click process?


  • conexware

    hello,

    what compression method is selected in the created 7z profile?



  • @Mili:

    hello,

    what compression method is selected in the created 7z profile?

    Generally, its LZMA2, but whichever it is, its the same as the test I perform using the multiple step process.

    So I am testing like for like here, not two different compression methods.


  • conexware

    Hello,

    What kind of a file are you compressing where you notice the difference?
    Also, please export your settings by going to Options>Save Settings to file" then compress them into a 7z or a Cab file and send them over to support at conexware dot com

    We will then try it out with your exact settings on a similar file as you and and see what we come up with.

    thanks!



  • I just got the same issue right now with RAR files this time.
    The file I’m compressing is called Ricochet Xtreme.exe and its 7,336KB in size.

    I set up the RAR Command Profile to have Maximum Compression and Default RAR5 Method with Solid Archive enabled.

    I compress the file by right clicking and selecting “Compress to xxx.rar”. The file size is 7,306KB.

    I now right-click and select Rar + Options and select Maximum Compression and Default RAR5 Method with Solid Archive enabled. I click add, and the file size is 7,304KB.

    Not much difference I know, but there should be NO difference at all, since its just the same compression just done a different way.

    Tried it more than 5 times each way, and the same results each time.


  • conexware

    @sjan26s2:

    I just got the same issue right now with RAR files this time.
    The file I’m compressing is called Ricochet Xtreme.exe and its 7,336KB in size.

    I set up the RAR Command Profile to have Maximum Compression and Default RAR5 Method with Solid Archive enabled.

    I compress the file by right clicking and selecting “Compress to xxx.rar”. The file size is 7,306KB.

    I now right-click and select Rar + Options and select Maximum Compression and Default RAR5 Method with Solid Archive enabled. I click add, and the file size is 7,304KB.

    Not much difference I know, but there should be NO difference at all, since its just the same compression just done a different way.

    Tried it more than 5 times each way, and the same results each time.

    you can set RAR command line options as you wish in Config…. there are a lot of switches that can be used.



  • @spwolf:

    you can set RAR command line options as you wish in Config…. there are a lot of switches that can be used.

    Well, its set as the defaults in ALL cases.
    I haven’t changed that in either case.

    I’ve run a lot of other tests, and the same result is happening all the time.


  • conexware

    Thanks for the info. I have tested a similar scenario compressing a RAR with compression profile options and then compressing into a RAR using the same options but in Compress w Options. The file sizes did turn out to be different so I’m logging this in so we can check it out.

    thanks!



  • Great.
    Its good to be believed that a problem did exist.

    The same issue also happens with 7zip also.


  • conexware

    picture tutorial 🙂



  • @spwolf:

    picture tutorial 🙂

    And?
    What does that mean?

    I already know about those settings…and surely they affect ALL RAR compression, no matter the method.


  • conexware

    @sjan26s2:

    And?
    What does that mean?

    I already know about those settings…and surely they affect ALL RAR compression, no matter the method.

    change your setting to indicated above and try compression test again. Thank you.



  • @spwolf:

    change your setting to indicated above and try compression test again. Thank you.

    Just did. And as I suspected, the results are exactly the same as before….the file sizes are indeed different each time…

    Issue STILL exists…


  • Alpha Testers

    Just checked mine and my RAR Maximum is different -> -m5 -mdg -mc10:128t



  • @ckit:

    Just checked mine and my RAR Maximum is different -> -m5 -mdg -mc10:128t

    That’s what I had also.

    But I changed it to just -m5 as suggested and ran the tests again, and that’s what I was talking about.


  • conexware

    @ckit:

    Just checked mine and my RAR Maximum is different -> -m5 -mdg -mc10:128t

    there were 2 problems, first setting was not compatible with later WR versions… so it was fixed. And then compress to .rar always used default one (compress with options used config setting as it should). Now both of these should work fine, check it out:
    http://dl.powerarchiver.com/2016/powarc160204.exe



  • @sjan26s2:

    I just got the same issue right now with RAR files this time.
    The file I’m compressing is called Ricochet Xtreme.exe and its 7,336KB in size.

    I set up the RAR Command Profile to have Maximum Compression and Default RAR5 Method with Solid Archive enabled.

    I compress the file by right clicking and selecting “Compress to xxx.rar”. The file size is 7,306KB.

    I now right-click and select Rar + Options and select Maximum Compression and Default RAR5 Method with Solid Archive enabled. I click add, and the file size is 7,304KB.

    Not much difference I know, but there should be NO difference at all, since its just the same compression just done a different way.

    Tried it more than 5 times each way, and the same results each time.

    this a file that is so small and if we compress small file so it change alittle bit
    like if you change a picture with 793KB after compress it would be 792KB or 792.5 KB because the picture size is so less and if we compress a file with 1.3GB after compress it would be 1.2GB or 1.1GB which reduce up to 100MB size
    so file compressing belong to file size
    and the file you want to compress is so small ( about 7MB) so if you compress this file it would be about 6.8MB
    hope to find the answer


  • Alpha Testers

    Do did the problem with 7z files mentioned in #1 exist or not?
    If so is it fixed or not?


  • conexware

    Hi Brian,

    We’ve just tested two files, a 170mb file and a 1GB file, via Compress to 7z and Compress w options>7z
    Compression profile changed to LZMA2 Ultra.
    Also tried with LZMA Ultra.

    In both cases, both files resulted in same file size of the compressed 7z file.
    Seems fixed.

    If you happen to come across a specific situation where the issue seems present, please let us know and we’ll test immediately.

    Thanks!


 

6
Online

9.8k
Users

6.0k
Topics

36.8k
Posts