CRC errors when working with WinRar ZIP files



  • Hi. I am using two PCs - one at work with old version of PA (named 2009, I can check the exact version number on monday if that helps you) and no way for upgrades (corporate policy, will be explained later) and another one at home with latest version of PA.

    Few weeks ago we were informed at work that PA is getting replaced with WR which is recommended to be used, while we may keep the old version of PA installed. And this is where the problem started. At work I am creating large backup ZIP archive (around 15 GB compressed) using Win Rar 5.00 x32 running under Windows XP Pro x32. Next I am copying it onto external USB HDD and getting home. I am copying it then from external HDD to my personal HDD. As always just to be sure everything went fine I run Test operation on this archive using PA 13.x. I got thousands of CRC errors. My first thought was that this file was corrupted while moving between HDDs. But that was not the case. I got my home HDD hooked to work PC and the Test procedure went fine using WR 5.00 and PA 2009 that I got there installed. So knowing the file is not damaged I’m back with my personal HDD to home. It seems PA 13.x is wrong claiming there are CRC errors. Just to be sure I have installed at my home PC trial version of WR 5.00 (x64, running under Windows 7 x64) and the Test procedure is completed just fine. I can extract every file from this archive and they are working fine after that. So I did upgrade from PA 13.x to PA 14.01.06 - still same situation, thousands of CRC errors while running Test procedure.

    Looking closely into that case I was able to isolate the problem. PA 13/14 claims there is a CRC error only on files inside this ZIP archive that have unusual characters in their filenames. By unusual I mean common Polish national characters that can be found in Windows-1250 charset (e.g. Unicode #017A character). All other files can be extracted and working file when using PA 14.

    Any fix for this? It’s weird that old version of PA 2009 doesn’t have this bug, but it could be related to new multicore ZIP engine that was introuduced somewhere between those versions…


  • conexware

    can you send us one example archive but with single file or something like that? I cant tell you whats wrong before checking it out.

    WR has pretty wonky ZIP support, it is better to use RAR which you can open with PA. They have multicore support for RAR, I dont think they do for ZIP, so it will be faster that way.

    We always have to add workarounds for various different archivers that dont implement perfect support for zip specification.


  • conexware

    you can send archive to support at conexware dot com… much appreciated!


  • conexware

    Hello, I attempted to reproduce this by including the Unicode #017A character in a filename and creating an backup archive via WinRar 5.00
    Tested in latest PowerArchiver and it worked fine.
    If you can, please do send over a sample archive to support at conexware dot com and we will take a closer look

    Thanks


 

2
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy