Test tool in shell extensions


  • Banned

    Having dealt with my own particular quirks and raised a silly issue, I think this is a real one.

    I have “test” selected as an option I want in the shell main menu.

    But it doesn’t show up in the shell either within the PA window or within explorer.


  • conexware

    is it 32bit Windows or 64 bit? I tested it on x64 and seems to be fine…i added it to submenu and showed there when clicked on zip archive… what archive did you click on?


  • Banned

    32 bit

    click on several archives. zipx and 7zip


  • Banned

    I show you the setting in shell.

    My screen capture program won’t let me capture right menu options within PA; but here is explorer RC menu.
    attachment_p_31373_0_test1.png
    attachment_p_31373_1_test2.png


  • conexware

    ok, mili will check with 32bit when he signs on after his festivities come to the end (eating a lot of cookies due to holidays)


  • Banned

    I thought perhaps relocating in on the ribbon might have made a difference


  • Alpha Testers

    Works in Vista 32bit. Tried a few different archive types for testing.
    attachment_p_31376_0_testshellext.png


  • Banned

    I Use Win 7

    Perhaps it works, too, if I break it apart into all the sub areas. But I don’t want to do that. Context menu is too cluttered as is.

    I can get it to show up if I add it to the sub-menu (which, I think, is what Luxor has done). Could you try adding it to the main menu and see what happens?


  • Alpha Testers

    @Socrates:

    I can get it to show up if I add it to the sub-menu (which, I think, is what Luxor has done).

    Yes that’s how mine is set up.
    @Socrates:

    Could you try adding it to the main menu and see what happens?

    Anything to oblige. 🙂

    No problem set up like that neither.
    attachment_p_31378_0_testshellext2.png


  • Banned

    Then either it is Vista versus 7-32 . . . or something else (one different setting?

    Never been a problem before.

    I can live with it in sub-menu, but since I use it a lot, I would have preferred. . . .


  • Alpha Testers

    @Socrates:

    Then either it is Vista versus 7-32

    Vista does something better than win7, that’s got to be a first. 😉

    @Socrates:

    I can live with it in sub-menu, but since I use it a lot, I would have preferred. . . .

    Have faith in the team, they are good at finding and fixing our own little personal issues. 🙂

    Except for a couple of my personal little ones. 😃


  • Banned

    The test tool – even when it does appear in the sub-menu – does not work.

    First, it asks me for the proper file association, and then just opens the PA window where I can, if I wish, test the archive.

    But this is multiple steps for what should be two clicks (right context menu / test).


  • Banned

    One more thing. I have “Test” on the QAT. But I cannot use it even when I have selected an archive. I actually have to open the archive.

    That seems like an unnecessary step.


  • conexware

    for Test there needs to be archive opened… it doesnt have an interface of its own.


  • conexware

    @Socrates:

    I Use Win 7

    Perhaps it works, too, if I break it apart into all the sub areas. But I don’t want to do that. Context menu is too cluttered as is.

    I can get it to show up if I add it to the sub-menu (which, I think, is what Luxor has done). Could you try adding it to the main menu and see what happens?

    send over your settings and we will try with them and see what happens on our test computers… maybe it wont show up either.


  • Banned

    I have used test within the shell for as long as I have used PA. I did not have to open the archive . . . just have it chosen.

    Have you decided that they will no longer be true? I can live with it within the sub-menu, as long as it works the way it used to.


  • conexware

    @Socrates:

    I have used test within the shell for as long as I have used PA. I did not have to open the archive . . . just have it chosen.

    Have you decided that they will no longer be true? I can live with it within the sub-menu, as long as it works the way it used to.

    no, i was talking QAT and inside main PA. In the shell, it should work same as always, there were no changes in any case, just repositioning one button.


  • Banned

    I stumbled on a solution. After brief tinkering, (a) “test” appeared in the main shell menu, and b) I could run test immediately, just after selecting the archive, just as it has always done before.

    The problem - unfortunately - is that I am not 100% sure what I did. I was tinkering with adding and deleting several other items in the shell extensions menus. (I thought tinkering with the menus might yield a result.)

    I THINK this is what I did:
    Under compression:
    1. removed compress to RAR

    Under extraction:
    1. ended up with “extract archive to” and “extract archive here.” I either had one but not the other; on even took one off and added it back on.

    In any event, shazzam: test showed up and worked correctly, both in explorer shell AND in right clicking within the PA window. It did NOT take to me to the PA windows or require me to actually open the archive. Just selecting it was enough.

    If you want, I can send you the new registry keys, and you can compare them with the one I sent this morning. Perhaps you can isolate the exact difference.


 

3
Online

9.7k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy