Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Virtual Drive Issue



  • I have reported this before but not pursue it too much here. I use another drive emulator which works perfectly. But I don’t like computers to win!

    The problem is that when I mount an image file, a drive letter is not given, and unmounting the image a) does not clear it from the wizard and b) a second attempt causes a BSOD crash. There are no other issues with my Win 7 x64 installation regarding drive letters or partition management.

    The virtual drive does work on other windows setups so something strange is going on. I have searched for similar issues and turned up nothing. I am using the latest drivers, viz SPTDinst-v183-x64.

    Any ideas?

    Regards

    DrT
    attachment_t_5788_0_2013-05-25_15h45_06.png


  • conexware

    strange… nobody else reported something similar, maybe something is clashing? Lets see with upcoming 2013, soon.



  • I have not got a hope in hell of tracking this down as everything else works fine. I can create drive letters without issue too.

    The only hope would be if somebody else were familiar with this. Will 2013 deal with the virtual drive feature identically or will it have been modified in some way?

    Regards

    DrT


  • conexware

    there is some new code so we will see…



  • After reading some other posts about issues being fixed by an uninstall and then a reinstall, I gave it a go and it’s fixed. UPDATE:-only fixed for one go. Does the uninstall clear out all the registry settings? If not, howcan I start from a default install?

    Thanks

    DrT


  • conexware

    thats strange… beta should be within 7 days.

    wait, how come you are not alpha tester?



  • Still having the problem with the beta (14.00.16).

    I am having the same issue with Starburn software (I believe that you used the SDK?) except that Starburn can remove a non-showing drive. These drives to not appear in Disk Management so I cannot manually add a letter.


  • conexware

    i wish we could reproduce it here somehow, would give us ability to troubleshoot it.



  • I am happy to run any tests or debug version or do any registry editing/sleuthing to assist. Do you get any preferential treatment from the StarBurn people as you are developers rather than end users? I have also left a message on their forum.

    Regards

    DrT



  • hi,
    i’ve got exactly the same problem with the virtual drive.

    • i had elby’s virtual clone drive installed.
    • uninstalled it, bit didn’t reboot (probably a mistake).
    • downloaded and installed virtual drive through patchbeam.
    • then tried to mount an iso, which caused windows to try to install a driver, but ended in a loop. tried shutting windows, which didn’t work.
    • had to do a hard power off. then reboot.
    • after reboot tried again to mount iso, which worked
    • dismount iso also worked
    • tried mounting the same iso again -> no response
    • tried to dismount the iso (which ha no drive letter assigned to it)
    • tried again to dismount the iso, which now hat two entrys in the list of mounted drives (again without any drive letters)
      -BSOD

    i use intel raid storage drivers



  • I supplied all the info Starburn requested and they could not see anything wrong. They did not reply to my last email (just come back from hols) so have sent them a ‘bump’.


  • Banned

    I can mount a virtual drive just fine.

    And I can unmount it from the system tray. No problem.

    However, the “Unmount virtual drive” from within the Windows shell does not work. I DO get a message near the tray saying that the drive is unmounted. However, the drive still shows as an active drive within Windows explorer.

    So the problem I have is just with the shell option.


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.