Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

AutoUpdates not working

  • Hi guys,
    I’ve been using PA for many years now, but this Patchbeam technology is a pity. While it’s working fine on my home network, it drives me crazy behind my corporate firewall and proxy.

    I’ve entered my proxy information in the settings dialog as with most other programs. But whenever I start Patchbeam (or PA does it by itself), the complete interface freezes for several minutes (~3-5) preventing me from using PA or aborting the updates. I just used Process Monitor from Sysinternals to check what’s going on.
    What irritates me are several things:

    • I cannot see any network activity neither from the POWERARC.EXE nor from the PatchBeam.Exe
    • Although these two processes are creating >20000 file and regsitry accesses during the first few seconds, they seem to completely sleep for the rest 4 minutes of freezing
    • After Patchbeam starts, It takes around a minute to display the special news in the lower half
    • After the five minutes, PatchBeam teel me there were no updates found and that my currently used versions (PA 12.12.02, PB 1.01.07) are the most recent

    This leaves me with 3 questions: Why does it take so long? Why is it freezing and which process actually tries to get the updates from the server? And shouldn’t it show me PA 13 as an update?

    Before you ask: The behavior is the same since PatchBeam was introduced - it never worked for me. It also affects every machine in using in office. So currently I have to update manually and disable PatchBeam completely.

    Any help is appreciated 🙂

  • conexware


    There is obviously problem due to the firewall, it seems it gets blocked by something… possibly AV as well? Because if it shows empty, it means it could not access the internet.

    As to the news, thats displayed by Internet Explorer system control, actually not PowerArchiver itself. So if it shows after a minute, thats not related to PA itself.

    We need to setup something similar to see why is it not working.

  • Hi spwolf,
    I also believe that the request gets blocked somewhere. But I believe more it’s a proxy problem and not a firewall one (as long as you’re not using special ports). The firewall would ask for access and despite that, it works with other programs flawlessy.

    I just tried to install the Virtual drive at work - no chance. This time patchbeam just closes without any message after searching for a while. No error, no success - nothing.

    Could you maybe give me an example on how a working proxy configuration looks like? Or how I could check that PA is actually using the proxy that I’ve entered in the options dialogue correctly?

  • conexware


    Here is the direct link to PA’s VD drivers;

  • conexware

    let us know if the link works properly or not…

  • Sorry that I didn’t reply. Yes, the link worked. But I had some problems updating PA and since I was in a hurry, I manually reinstalled everything instead of trying to get Patchbeam to work. I anyway have the feeling, that over the years PA updates had some leftovers and the Patchbeam/VD updates and drivers weren’t cleaned up correctly (do you have by chance a removal tool to clean up everything?).

    However, even with the current version of PA and Patchbeam on a different PC, the problem still persists. I now have another computer, where I would like to install the VD driver, but the Patchbeam process hangs completely until I kill it. (I know I could use the direct link, but I want PA to work correctly 😉 )

    For me it looks like it either can’t get through the proxy or it uses a different port which might be blocked.

    I’ve entered my proxy details (host+port, no login) in the settings and after a couple of tries (with and without “http://” in front of the hostname) I think I’ve managed to get the normal update running. At least I can see it connecting to the proxy as well as trying to reach (what is that??). However, the process still hangs for >1 Minute until telling me there is no update (which is wrong, since I still have 14.01.06).

    But if I click the Virtual Drive button and accept the popup to download the drivers, the Patchbeam process never tries to connect to any server. I can see that it gets called with different parameters and apparently doesn’t even try to read the proxy settings or connect anywhere. It also never shows this AD-Frame in the lower section.

    Could you give me an example of correctly entered proxy settings (I mean the format), just to be sure?
    In the options I can check “Use Debug version of PatchBeam update system” - what does it do? Could it help to investigate the problem?
    Do you have a proxy environment where you could check such things? 'cause I have the feeling that this never worked 😉

  • I have always loved the idea of Patchbeam and in most circumstances it works.

    However, going back to when we were testing during Alpha, beta and Release phase this was something I raised a few times suggesting the application hung and wasn’t very helpful when things didn’t work.

    For example, things I have requested in the past were;

    1. Test Connection (before it proceeds to open Patchbeam) this would be helpful with FTP as well.

    2. Turn on or off News page (at bottom of patchbeam) this I find slows things down on poor networks or systems with highly restrictive firewalls etc.

    3. Direct download links (old fashioned way to obtain full downloads should PB not function)

    I have had in work networks countless issues and even when I have configured everything I can it would still not work.

    Typically, if you want the best use your Internet Explorer’s LAN settings as an example for connection as in most businesses they filter this through their proxy firewall.

    The catch is many companies block “unknown” or “misc” traffic and unless you report it then it will remain blocked.

    This is to help reduce the load on the network and increase security. Obviously, the firewall doesn’t know PowerArchiver is a safe application its up to the IT dept to make that adjustment.

  • I’m glad to hear that I’m not the only person having issues with PatchBeam behind Firewalls/Proxies.
    I fully understand the reasoning behind such measures (I’m a software developer myself) and I also know the correct settings for my network here.
    I also fully agree to all points you mentioned.

    Having a connection check in advance would really help here, since I don’t even know whether PA is using my proxy settings, whether they are correctly parsed or where the problem is.
    As long as PA only uses a normal http connection, there shouldn’t by any firewall issue apart from the proxy stuff.

  • conexware

    It seems to be proxy/firewall issue… when it comes to PAVD installation, it is very simple and not usual Patchbeam mode where we patch the changes via our engine.

    Basically here is how it works (for PAVD):
    a. Downloads txt file on our server to see what is the latest release.
    b. Shows update option if there is new release.
    c. Downloads full installation file, closes PA and executes it.

    For the Patchbeam update of PA, it seems that it is not actually downloading the txt file with the update - basically it times out after 1 minute since it is not getting the file. What it is likely working is downloading of file in IE frame below.

    Cachefly is CDN provider we use for all of our downloads… they have servers around the globe and you go to the closest one for the best speed/reliability.

  • Thanks for the info spwolf. But then this looks like a bug to me, since PAVD is not using the proxy settings and instead tries to connect directly. So basically, I see 3 issues here:

    1. PAVD installation doesn’t use proxy settings
    2. Patchbeam update doesn’t use proxy settings correctly (or connects via a non-standard port)
    3. Both variants don’t give any feedback to the user what went wrong and freeze the whole application completely

    I anyway never understood, why the Updater is a modal window and doesn’t allow me to continue using PA.

  • It would be good if the Patchbeam application had a option to collect a debug text file detailing what went on in the background… ie like you see during FTP… making connection, logging in username , logging password, syncing , approved etc

    so for this attempting connection, logging in , Error leaving proxy.

    The autoupdater dialog is not that different from other applications Avast, norton etc have it built in and if theirs crashes it can cause the application to require a restart. However, they have autodetect features that try’s to establish a connection using its own code logic.

    I wrote something similar
    1. Code uses the settings provided by IE Proxy settings
    2. If user enters in details it uses this instead
    3. if neither of the above worked it then attempts some alternatives
    4. if 1,2,3 fails it prompts the user requesting advanced details.

    but take into consideration the auto update hasn’t really changed since it was 1st introduced and for the majority of users it works.

Log in to reply

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.