Extracted File Immediately Deleted



  • I have a gzipped raw access log file produced by a Linux (Apache) server. The file name is of the form sitename.com-month-year.gz. Note the two periods in the file name. The gzip file contains a single file with the same name except without the extension (sitename.com-month-year).

    A. The first time that the file is available, it can be successfully extracted to a new folder.

    B. Later a revised gzip file of the same name becomes available. I try to extract this new file to the same folder overwriting the old one. PowerArchiver asks Confirm File Overwrite? Judging by the file sizes, it wants to replace the old extracted file with the new compressed gzip file. (90 megabytes replaced by 5 megabytes.)

    I answer Yes. The extraction process runs. PowerArchiver again asks Confirm File Overwrite? Now it wants to replace the 90 megabyte file with one with a size of 0 bytes. Before I can respond, the original 90 megabyte file is deleted from the folder. (After this it doesn’t matter what I answer. The original file is gone. The folder is empty.)

    C. I run the extraction process again, answering Yes again to the overwrite question. Now PowerArchiver wants to replace the non-existent 90 megabyte file with the gzip file. The extraction process runs and the created file is immediately deleted.

    D. Now I delete the empty folder and start the extraction again using the destination written in the extraction history menu. The extraction runs immediately but the file is again deleted right after creation.

    E. It appears that if I enable the Overwrite Existing Files option AND delete both the old file and its folder, I can use PowerArchiver to create a new folder and successfully extract the file. Strangely, the extraction process runs twice but at least the file is not immediately deleted.

    Is there a way to get this file extracted easily?

    Windows XP, PowerArchiver Version 13.00.22


  • conexware

    can you send us those files to test somehow? Best via support:
    http://www.powerarchiver.com/support/

    (link to the files?)

    that would be very helpful!



  • @spwolf:

    can you send us those files to test somehow? Best via support…

    I sent the links to two files using the support form. See Ticket ID: 25938.

    By the way, I don’t think this happened with earlier versions of PowerArchiver. I think it started in the last month or two.


  • conexware

    This is new version PA 2012 RC1 13.00.24:
    http://dl.powerarchiver.com/2012/powarc1300rc1.exe

    This should work now!

    Please check and let us know!



  • [QUOTE=spwolf;29431This should work now!
    Please check and let us know!

    Nope. Still broken. Here’s the steps I used to test the new version.

    A. Downloaded and installed PowerArchiver version 13.00.24.

    B. Downloaded a new compressed raw access log similar to the one I provided a link to in Support Ticket ID 25938.

    C. Opened the destination folder to watch the progress of the extraction.

    D. Invoked PowerArchiver by opening the compressed (.gz) file.

    E. Started the extraction.

    F. The PowerArchiver progress bars advance to 100 percent and a file is written to the destination folder.

    G. The uncompressed file is immediately deleted.

    In an attempt to find other failure modes, I deleted all files from the destination directory. Then I tried the extraction again. Now PowerArchiver asks me to confirm a file overwrite. It wants to replace a non-existent file of about 103 megabytes with a file of the same name with “?” bytes. It’s confused but I answer Yes anyway. The extraction takes place and the file in the destination directory is immediately deleted.


  • conexware

    please send us 7zipped your PA settings that you can save via Options> Configuration> Save settings to a file.

    Previously it extracted the file 2x in shell, 3x in main PA, but for me now it works fine.

    Here it never deleted the file. It might be connected to your settings, or maybe AV?



  • @spwolf:

    please send us 7zipped your PA settings …

    I have attached CMB_PA_Settings.7z to Ticket ID 25938.



  • to try and solve this i had a similar problem to this a while back when i had a rouge program on my stem it would delete files of certain types after i extracted them from Pa could that be the problem



  • About a week ago I received a note from support on the trouble ticket that I filed. They have reproduced the problem in the 32 bit version of Windows. Eventually a fix will be forthcoming.


  • conexware

    Hi,

    please check PA 2012 13.00.25 via Patchbeam and see if it works better now… thanks!

    p.s. problem was that for these files (not every gz!), under 32bit, PA engine would set the files with hidden flag, so they ended up being hidden :-).



  • @spwolf:

    …check PA 2012 13.00.25 …and see if it works better now…

    I installed 13.00.25 and restarted my computer. I opened one of the raw access logs that always failed before. Now it extracts the file and does not delete it.

    We’re now back to the PowerArchiver I remember. Whatever was broken in version 13 is now repaired. 🙂


  • conexware

    great!


Locked
 

9
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy