Scheduled backups in the 57th century



  • I just purchased a new machine and installed PowerArchiver and set up a scheduled backup using the .pbs file I brought over from my old machine. Oddly, it scheduled the backup to occur weekly starting sometime in the 57th century (if memory serves). I ignored that at first, since I was annoyed with the OEM crud installed on the machine. So, I erased the machine and installed Windows again from scratch using my own Win7 disc.

    Much to my surprise, a second install of PowerArchiver resulted in scheduling the backup again sometime in the 57th century. I looked in the .pbs file and the only thing that looks like a timestamp is FTDate (with a value of 931201024, which would be July 5, 1999). Not sure what that is.

    So I went into Windows Task Scheduler and fixed it there. I hope it works 🙂

    While I was in there, though, I found that there were about 10 or 12 PowerArchiver entries! I don’t know what they were for, but I deleted all of them, except for my backup script. (If they should be there, I can re-install.)

    Anyway, have others seen this issue? Is it related to scheduling an already existing script?

    I’m using Win7 64-bit and PowerArchiver Pro 12.11.02.


  • conexware

    maybe if you attach the pbs here we can try to reproduce it… they were all probably backup entries for that pbs, we dont use scheduler for anything else.



  • Sure. I just did it again and got similar results.

    I’ve attached the backup script.

    Here’s what I did:

    1. Launch PowerArchiver
    2. Go to Backup
    3. Select this backup entry (it’s the only one)
    4. Deleted it
    5. Closed PowerArchiver
    6. Noted the backup was still in Task Scheduler, so I deleted it from Task Scheduler, too
    7. Started PowerArchiver again, go to backups
    8. Copy my PBS file back into place (u:\lib\config\…)
    9. Click “Edit” and select my PBS file
    10. Click “Next” until I get to “Scheduling Options”. I note I can select a time, but not a date.
    11. I click “Advanced Options”
    12. I click on “Schedule” – it only gives me 3:30 on 2/10/2012 as the only option (I wish I could select the exact day)
    13. Click OK
    14. Back to The “Scheduling Options” page, I just click Next
    15. I see the list of files
    16. Click “Close”
    17. Backup entry does not appear in the PowerArchiver window
    18. So, I close PowerArchiver
    19. I re-start PowerArchiver
    20. I click on “Backup”
    21. The back is now there, set to start at 3:30AM on 6/9/5518. (I’m not sure why it selected a new century this time, but perhaps I am mistaken and it was 55-something before.)

    I looked in Task Scheduler and I see the same year: 5518. At least they are consistent, though not was appeared when setting up the schedule.

    I hope this helps. I can live with the work-around of modifying the entry in Task Scheduler directly, but there appears to be a few bugs in the scheduling area. I’ll not dismiss that it might be my machine, but it certainly is odd that I saw it twice.

    That said, I had a perfectly good working pair of USB headphones that refuse to work properly on this machine. Skype complains that it cannot grab the recording device when a call comes in. Swap out headphones with a different pair – both Plantronics USB headsets, but different models – and it works. Go figure. Computers. 😉

    (I tried everything software-wise I could do to make that headset work, BTW. It was actually the frustration with the headset not working properly that I re-installed, because I was convinced that Dell must have installed some kind of crap that interfered with the USB audio driver. You know how they pre-load the machines with all kinds of stuff you’d never use, which is why it’s pre-loaded with crap: they have to give it away. I was wrong about the pre-loaded crap being at fault, but who would have thought the headset was the issue when they worked on the Win7 64-bit machine I just replaced… I’m still puzzled with that one. Everything else on the machine appears to be working, though. After the headphone experience, which I am sure are still perfectly working headphones, I dare not suggest these PowerArchiver issues have nothing to do with my hardware. I’m convinced anything is possible now.)

    Paul
    attachment_p_28094_0_sydney-backup-script.zip


  • conexware

    it seems to me that importing pbs schedule from another computer could be at fault… we will check it out and thank you for the report.


  • conexware

    try attaching pbs now btw 🙂



  • Sorry about missing that. I did edit and attach it. I didn’t notice that it told me the attachment type was invalid. I clicked through to quickly. 🙂

    Let me go create one from scratch and see what happens.


  • conexware

    hm, seems to work for me here… can you try starting PA with administrator rights and then do the same thing with pbs? Maybe it is something weird with scheduling permissions…



  • I went through the steps of creating a backup. I left all of the options as default, except I selected the day for the weekly backup to start tomorrow at 3:30AM. When I got done, the PBS file was created, but did not appear in the PowerArchiver window. I exited and re-restarted PowerArchiver and it appears now, again with the date 6/9/5518. At least it’s consistent.

    I then did it again, selecting the time and weekly backup. However, I did NOT push the “Advanced Options” button on the “Scheduling Options” page to select the day of the week. This time, it created the backup with the correct date of today and for weekly backup. So, the problem appears to be related to trying to select the particular day of the week.


  • conexware

    i got it… when you go to advanced settings and save them, that appears… weird! should be fixed soon. thanks!



  • Great! I’m feeling good to know that I don’t have another mysterious USB headset-type issue… 🙂


  • conexware

    it is always a lot easier when we can reproduce it on our end 🙂


  • conexware

    Please Patchbeam the latest update and see how it works now… thanks!


Locked
 

6
Online

9.8k
Users

6.0k
Topics

36.8k
Posts