7zip - filename encrypt



  • After deleting a file from a .7z file, the filename encryption is lost. Files are still encrypted but visible when opening the .7z file.

    Using Ver:12.10.05 (01/2012)
    Windows 7(64)


  • Alpha Testers

    confirmed also in 12.50.03


  • Banned

    Same here.

    But a question.

    I didn’t think you used to be able to delete single files in 7z? Or was that only with a solid archive?



  • Don’t know about a solid archive. This problem was in ver. 11.71.04. Upgraded in hopes it was fixed. Right now my only work around is to extract and re-compress using the ‘Encrypt filenames’ option.


  • Alpha Testers

    yes in a ‘solid’ archive the ‘delete’ option is unavailable.



  • Sounds like the process in which is recompiles the archive doesnt include encrypting the names again.

    PA team should have a new version out soon, it contains many bug fixe’s so its worth keeping your eye open and updating patchbeam so it checks on start.



  • @moles42:

    yes in a ‘solid’ archive the ‘delete’ option is unavailable.

    My observations:
    1. If solid archive is selected in the 7-zip format and Optimized, LZMA or LZMA2 is selected, the Delete is unavailable.

    2. If solid archive is selected in the 7-zip format and Store is selected, the Delete is available.

    3. If solid archive is selected in the 7-zip format and PPMd is selected, the Delete is unavailable, but the file names are NOT encrypted.


  • conexware

    thenks guys! confirmd this one, logging it in!!


  • conexware

    *thanks 🙂


  • Banned

    I was initially perplexed when one user talked about exactlng a single file from a 7z file.

    I thought that perhaps this was a new development.

    I realize the problem is more complex.

    Suppose. when I create an archive, I create a 7z file; then I can delete an individual file without a hitch (although it then no longer hides the names of the individual files – still a problem).

    But I tried something else.

    If I CONVERT the file from zipx to 7z, the option to delete an individual file is greyed out, whether it was a solid archive or not.

    So perhaps there’s a hitch in the convert program (which is one of the great features of PA).


  • conexware

    it is probably always solid in converter…

    i also wonder if there should be some improvements to the converter?


  • Banned

    Definitely, that would be nice. I would use 7z more often.


  • conexware

    if you have any more ideas about converter, best time to make your voice heard in wishlist forums 🙂



  • Well here we are almost 6 months later and 13.00.17 still does not have the fix. Not a happy camper that they forced me to upgrade and pay….


  • Banned

    I think I must be misremembering the thread. My 7zip filenames are hidden until to enter the encryption key.

    Is there some special way you are adding the files?

    It is true that it doesn’t do it automatically from the shell (compress to 7 z) . . . but that is because (as far as I can tell, that is not an option when determining compression profiles.

    BTW, I am still using 12.12.


  • conexware

    Same here, works just as Socrates mentioned using 13.00.18.

    How are you adding the files?


  • conexware

    Also, PA will never force you to purchase an upgrade.
    The upgrade notice in Patchbeam specifically noted that new codes were necessary, that’s all.
    new registration codes can always be retrieved from your account at www.conexware.com/shop

    If you’d like, we will gladly refund your latest order.



  • The original post was:“After deleting a file from a .7z file, the filename encryption is lost. Files are still encrypted but visible when opening the .7z file.” BTW, the archive is not solid.

    Adding file is not the problem.

    This has been confirmed by a few member.

    Just tried it with 13.00.18 and the problem is still there.



  • @Mili:

    Also, PA will never force you to purchase an upgrade.
    The upgrade notice in Patchbeam specifically noted that new codes were necessary, that’s all.
    new registration codes can always be retrieved from your account at www.conexware.com/shop

    If you’d like, we will gladly refund your latest order.

    Oh well, done is done. Shame on me.


  • conexware

    The bug is still logged into our system from initial report. Going to put it on the next list of bugs to be taken care of, so let’s see what happens!
    Thanks for bringing it up again!


Locked
 

6
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy