PA screen position



  • Hi again,

    I like to use my Windows XP task bar (the bar with Start button 😃 ) in the upper part of the screen (like Mac style…).

    However, this PA version sometimes starts in the upper part of the screen, behind the task bar!

    So, I’m not able to move PA window using the mouse (the right click in PA task bar button does not show a “Move” option). I have to resize task bar to get access to PA and, then, move it down…

    It’s quite annoying and I don’t remember last version (8.xx) did that…

    I hope there’s a workaround to fix this.

    🆒



  • I’m still testing PA…

    Today, PA went out of screen…

    Something is wrong with the way PA saves its position… 😕



  • I’m wondering if the PA screen position weird behavior is happening just with me… 😕 😞



  • @Carlospr:

    I’m wondering if the PA screen position weird behavior is happening just with me… 😕 😞

    I think so, never had problems with that.

    Maybe you are using 2 screens or there is an virtual desktop function active ?



  • No and no…

    The first thing is that I use Windows task bar in the upper part of the screen.

    Second, if I download a zip file and press open, PA opens normaly. Then I make a second, third download and each time I press open… PA opens but its screen position change is getting higher and higher… If I resize Windows task bar PA title bar turns visible again…

    😕


  • conexware

    I couldn’t reproduce the issue - checked with taskbar on the top on Windows XP.

    Can you please run PowerArchiver, and from Options menu choose “Set installation defaults”, then close PA and try using all again?



  • Hi Ivan,

    I made what you said but the issue still remains. I also uninstalled PA and then reinstalled with no results…

    I changed the Windows XP taskbar to the botton of the screen and then PA position was recorded normally. Everytime I started PA it started at the same screen position.

    I placed the Windows XP taskbar to the upper position again and I got the same issue: everytime I started PA it started at a higher screen position…

    Then I decided to install version 8.60: it’s working normally, even with the Windows XP taskbar placed at the upper screen position…

    😕



  • Hi,

    Just noticed this and thought I’d try it. I can reproduce the problem. Try the following: move the Windows XP task bar to the top. Right-click on the task bar, select Properties, and disable AutoHide. This ensures that the task bar is always visible, and that all currently visible icons and application windows are pushed down by the width of the taskbar.

    This gives rise to the concept of having different logical and physical screen coordinates. The logical screen coordinates start at the bottom of the task bar (since nothing but the task bar itself can appear above that position), whereas physical screen coordinates start at the top of the screen.

    Now start Power Archiver. Notice where it has positioned itself. Without changing that position, do something with it, e.g. view an archive (if you just exit without doing anything, it may not bother saving its last position). Now exit Power Archiver, and start it again. You will notice that its screen position has shifted up a bit. The amount it has shifted is the width of the task bar. It is as if, on exit, it saves its position using logical screen coordinates but, on start up, it restores its position using physical coordinates.

    HTH,
    Klitos



  • Thanks klitos for your great issue analysis!

    That’s exactly what is happening!


  • conexware

    Thanks klitos!

    The bug will be fixed in next release!


  • conexware

    Hi,

    please check it with 9.00.35 release:
    http://www.powerarchiver.com/test/powarc90035.exe

    And make sure you test it a bit so there are no other issues.

    thanks,



  • The new version was tested for some days and it’s working!

    🙂


 

2
Online

9.2k
Users

5.9k
Topics

36.4k
Posts

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.