Error when using shell extensions and Total Commander



  • I’m using PowerArchiver since years and never had problems with this. Actually I’m using PA2011 with Windows 7 Home Premium x64.

    Now I bought the program Total Commander and every time I rightclick on a file or a folder Total Commander is crashing down.

    With ShellExView I tried to disable all shell extensions which are not from Microsoft. So Total Commander did not crash any more. But after enabling the shell extensions from PowerArchiver Total Commander crashes down when right clicking.

    Is there any possibility to fix the shell extensions so that Total Commander works without crashing down?


  • conexware

    is TC 32bit or 64bit? Problem might be our 64bit shell extension then?


  • conexware

    ok, so I tried:
    PA 2011 12.01.03 Int
    TC 7.56a

    on Win7 64bit.

    All works fine… both 32bit and 64bit shell ext work fine, and even UAC elevation works as advertised.

    Maybe you are using different version of TC or PA? If not, maybe some PA setting is different? Send us your settings via Options> Save (7z first), to support at conexware dot com and refference this thread…

    thanks!



  • I’m using TC 8.0 beta 7 x64 with PA 2011 12.01.02 GER.

    Saved my options, zipped the reg file and sent this to you…

    Best regards,
    PoooMukkel


  • conexware

    did you try reporting this to them? This seems to be the issue with their 64bit TC that just came out. Same PA works fine in their official release.

    Keep in mind that this is first release of Delphi 64bit, so these issues will arise.



  • Yes, I reported this to them. But they said that it must be a shell extension which works not correctly. So they put me to ShellExView and I disabled all of the non-Microsoft extensions. Then I enabled them one by one and tested with TC.


  • conexware

    it worked fine in 7.65a, it works fine in Explorer… just doesnt work in their betas and new 64bit code :-).



  • Ok… That’s a fact… 😉

    By the way I tested WinRAR and their shell extension works fine with the beta of TC.

    I don’t know what to do now. I asked again in the forum from TC. Hopefully there will be a fix. 😞


  • conexware

    @PoooMukkel:

    Ok… That’s a fact… 😉

    By the way I tested WinRAR and their shell extension works fine with the beta of TC.

    I don’t know what to do now. I asked again in the forum from TC. Hopefully there will be a fix. 😞

    tell them it works fine in official release, just not in their new 64bit release, and that works fine in x64 Explorer.



  • Okay, I will try…


  • conexware

    anything?



  • Sorry for letting you wait…

    I asked the support from Total Commander. TC is only using 1 function for shell extensions. The rest is made by Windows. So they are not able to help. 😞

    But they showed me some workarounds for the problem. One is to use the x86 version of TC. Then it will work. Or using the x86 shell extension from PowerArchiver should also work. But I don’t know how to use the x86 shell extensions because I don’t have the possibility to install x86 version of PA on x64 system.

    May be you can do something in one of your next versions with the shell extensions? That would be great. 🙂


  • conexware

    did you have any luck with this?



  • No, I didn’t have. I’m waiting for another version of PowerArchiver. Hopefully the shell extensions will work then… 😉


  • conexware

    you can unregister x64 bit shell extensions, will that work?



  • What does that mean? And how can I do that?



  • I don’t know, how to unregister x64 shell extensions…

    Installed PowerArchiver 2011 V12.10 but shell extensions still not work with Total Commander 8 Beta x64. 😞


  • conexware

    Go to cmd.exe
    and run:
    regsvr32 /u PASHLEXT64.DLL

    it will unregister 64bit shell extensions!



  • That does not work. There appears an error which I only have in German.

    [Window Title]
    RegSvr32

    [Content]
    Fehler beim Laden des Moduls “PASHLEXT64.DLL”.

    Stellen Sie sicher, dass die Binärdatei am angegebenen Pfad gespeichert ist, oder debuggen Sie die Datei, um Probleme mit der binären Datei oder abhängigen DLL-Dateien auszuschließen.

    Das angegebene Modul wurde nicht gefunden.


  • conexware

    you need to navigate to PA folder first, or else specify the path before… like C:\program files (x86)\powerarchiver\pashlext64.dll


 

5
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy