Unmounting Virtual Drive



  • Unmounting a virtual drive used to be almost instant. Lately, it has taken a few seconds (win 7 32 bit). One has to wait until all the notifications have gone (yes, those saying that the unmount has been successful šŸ˜•:)) until one can delete the image that had been mounted. Trying before that moment results in a delete failure as the file (image) is still in use. Using RC5.

    Regards

    DrT


  • conexware

    hey DrT!

    Which method are you using to unmount?



  • Right-click, unmount. I have always used this method.

    With kind regards

    DrT


  • conexware

    is it the same for you with all ISOs you try to unmount? no matter the size?

    just tested some here, unmounted instantly.



  • Hi,

    Try and delete the ISO as soon as you believe it has unmounted. When I try to delete, it is after the blue ā€œvolume unmountedā€ notification has appeared. So the unmount may have appeared to be successful, but the ISO is STILL in use by PA - there is a PA icon in the taskbar until the ISO becomes deletable - which is when the blue notification goes. I can produce a video of my screen showing all of this should it help.

    I would not have noticed this if I did not want to delete an ISO as soon as unmounting.

    With kindest regards

    DrT


  • conexware

    Thanks!
    Yes, tried it and was able to delete it immediately.

    have you tried another ISO file? same issue?


  • conexware

    since this has not been changed in a while, check what could influence that on your computer side.



  • @ Mili. Yes all ISOs affected.

    @ spwolf. Will do.

    Thanks to you both.

    DrT


Log in to reply