Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Cant delete files from local zip/x archives



  • I have several zipx archives which I am trying to clean up. I can open the archive and select a number of files for deletion, then delete them. The archive refreshes to show the remaining files.

    I then select a few more for deletion, confirm-at which point the whole archive clears. If I then exit PA and go back to open the archive, it tells me that it is Read Only and that I don’t have permissions to change this.

    If I delete one batch of files, and exit, I can then reopen the archive and see it minus the first lot of deletions. If I then try to delete some more, it deletes itself as previously described.

    The archive file is clearly deleted, because allowing for delay, browsing back to it with Explorer shows that it has gone.

    I am logged on as the Admin login created when initialising W7.

    I have a feeling this is about permissions, but I cannot see how. I confess to being rather new to W7, and managed to avoid the Vista experience, so XP is my last reference point.


  • Banned

    I have Win 7 32. I cannot duplicate the problem. So it may be permissions; or it may be something unique to W64.



  • This isn’t a problem if I create a TAR archive and do exactly what I’ve been doing on zips and zipx.


  • conexware

    we shall investigate, it might have something to do with specific zip archives.



  • Thanks spwolf

    I’ve also got the “hidden” super Administrator enabled and I’ve tried logging off the User/Admin to the super Admin and doing the whole lot over again, but this makes no difference.

    If I can figure out the wretched Snipping tool I may be able to put up some screenshots, but I don’t think they’ll tell anyone much.



  • I’ve spent some more time on this, including reinstalling PA, but nothing seems to alter the problem.

    This machine also has a couple of flash drives (FAT32) and two eSata/USB external hard disks which are NTFS. If I use PA on these external volumes, it performs exactly as required i.e. file deletion from the zipx archives works perfectly.

    I seem to be able to add files, test, extract and so forth with the problem system disk archives - it’s just deleting files from zip or zipx archives that’s the problem. Unfortunately the OpenFiles utility doesn’t work on 64-bit (without a lot of fiddling about) so I can’t immediately check to see whether something else has grabbed these archives.


  • conexware

    so if you copy the same archive to external drive and try the exactly the same action, it works?



  • External drives = fine, works as it should.

    Use any folder, any login on the system disk (C:, SATA) then the problem arises.

    I’ve checked the Recycle Bin and the archives are being deleted to there, although this isn’t evident straightaway (need to close and open windows in Explorer and then the file is seen to be gone).


  • conexware

    i couldnt reproduce it with my own computer… we will have rc4 soon so you can test and see if you can still reproduce the same issue.

    thanks

    p.s. i updated the thread title.



  • Thanks for that.
    In an effort to see whether the problem is in Windows or PA, I’ve tried to replicate the problem with the same archives but reluctantly using other compression software.

    This other rather clunky software works fine with my archives, so I’m thinking this isn’t a purely Windows-related problem. I didn’t mention it before, but my system is 64-bit in both hardware AND Windows.
    The other notable thing is that when these archives delete themselves after the second content delete attempt, they are well and truly gone, as no file recovery software can find them immediately after the event.



  • just a thought did you install any programs recently before you encountered this problem. SAlso one thiong to mention try running a chkdsk on your harddrive to see if there are no errors whixch could be causing this fault.



  • I haven’t installed anything recently, and I’ve run several chkdsks on this machine since I got it.

    There are a couple of things to check out which I will do today, but nothing obvious.

    The biggest problem I have is that I can’t remember when last I tried to delete files from an archive on this machine or the XP box, as they normally go into the archive for keeps. I do remember having an XP problem where a program (I seem to remember Copernic) grabbed the archive when I was deleting and prevented the files being deleted i.e. the reverse of what’s happening now.

    You have given me some food for thought on this.


  • conexware

    if you could get smaller archive where this is reproducible and send it over to support at conexware dot com , it would be very helpful…



  • I think that I may have worked this out, thanks to davidsplash.

    I mentioned that I’d had problems deleting files from archives in XP, and I’d been trying to recall what was causing it. I now remember that it was Memeo Autobackup, which you may know is an non-stop file backup routine originally provided with Seagate external drives.

    I don’t use Memeo on this machine, but I do have Acronis Trueimage Nonstop backup running. When I pause this, my archive delete problems seem to stop. When I restart Acronis, my archive problem recurs. This isn’t surprising, as Memeo and Acronis work pretty much the same, constantly detecting file changes for backup and grabbing open handles.

    I suspect that other archive operations and not just file deletes could be compromised by a running Non-stop backup.

    The moral therefore is that PA won’t happily co-exist with these two applications for sure, and perhaps other similar ones. I will take this up in the Acronis forum, but I doubt I’ll get very far.

    The options available are either to stop using nonstop backup permanently, or always try to remember to pause or halt it when working on my PA archives. As I value my archives and have other backup methods in place, I think that Non-stop will now become Stop



  • I am now certain that Acronis is the cause of the problem, and also explains some other curious behaviour in other programs.

    Its a bit odd that PA was affected whereas the “other zip product” wasn’t - not that I’m bothered now I know the fix for the problem in PA.


  • conexware

    @PA_Fan:

    I am now certain that Acronis is the cause of the problem, and also explains some other curious behaviour in other programs.

    Its a bit odd that PA was affected whereas the “other zip product” wasn’t - not that I’m bothered now I know the fix for the problem in PA.

    i do suggest that you report it to them… every program does something differently.

    once we have some time, we will check it out ourselves as well.


  • conexware

    of course, best is opening ticket with their support, not forums…. that goes directly to them.



  • No reply from Acronis as at 22/5/2011.


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.