Transparent handling of PAE file doesn't work anymore with 12.00.41



  • Hi,

    With the latest version of PO, 12.00.41, the transparent handling of PAE file doesn’t work anymore for saving a changed text file. If I edit a text file, PA ask me to update the archive when I save the file and I can see that the zip behind has been correctly changed. However, when I close the archive, PA doesn’t ask me anymore if I want to update the archive and left the PAE untouched, with the older version of the ZIP file.

    However, if I add a new file to the archive then yes, at the end, when I close the archive, PA ask me if I want to update the archive and process it correctly.

    The two options “Handle encrypted archive transparently” and “Ask to update if file has been changed” are checked.

    Furthermore, on Windows XP, when I close a PAE file, PA tell me thatthis archive was opened from a temporary Internet folder and ask me if I want to save it. This happens even if I did not make any change to the PAE file. In case I save it after having made a change, this is still only the older version that get saved and not the newer version with the new zip file.

    On Windows 7, this second problem doesn’t happen but the first problem still does.

    Thanks for your attention and regards,
    S. L.


  • conexware

    thanks a lot!


  • conexware

    this has been fixed with RC4?



  • No change with the latest version 12.00.49. I’ve tried both the update with PatchBeam and I’ve also downloaded and installed the rc4 release directly from the web site.

    Also, I’ve noticed something else: I’ve told you that if I add or remove a file instead of just changing a file that is already in the archive, it works. However, if I add a file and then, after that, I make a change to another file then the whole process of saving the archive is also cancelled. To be clear:

    1- I change (edit) a file: it doesn’t work.

    2- I add a new file: it works.

    3- I add a new file and then make a change to another file: it doesn’t work again.

    4- I change a file and then add another one: it works, as expected.


  • conexware

    i checked it during development of RC4 and it seemed fine… We will now update it soon during minor update period on the road to the final.

    thanks for the help.


  • conexware

    Hi,

    it works here - can you send your settings Options> save settings to support at conexware dot com, it might be some specific setting


  • conexware

    please patchbeam to .50 and try there, if it doesnt work, please send us your settings as noted above.

    that way we will be able to reproduce it for sure.

    thanks!



  • I also get this. Updated to .50 this morning, but still the bug prevails.
    Win 7 Pro 64-bit
    attachment_p_26364_0_pa12_conf.7z


  • conexware

    thanks!



  • Upgraded to 0.50 and the problem is still there. Here’s my configuration file for PA (on Windows 7 64 bit).
    attachment_p_26384_0_configurationforpa.7z


  • conexware

    thanks, we got crohans which enabled reproduction… should be fixed within days!


  • conexware

    Hi,

    .51 has just been published. It should fix this PAE issue, just patchbeam it!



  • Thanks, 0.51 fixed it for me!


Locked
 

3
Online

9.8k
Users

6.0k
Topics

36.7k
Posts