Extracting to NAS on Win 7



  • Hello everybody.

    Since latest version (11.63.14) I cannot extract to my NAS anymore. PA says, that it cannot write the files because they might be in use. I assume that the PA’s command “extract to…” runs as administrator on Win 7. This special admin accounts does of course not have rights to write to my NAS. Any way to get it working again?

    Kind regards
    Thomas


  • conexware

    try running PA as admin and see what happens then.
    If it works, then set it up so PA always runs as admin.

    PA always runs as user, so extract to runs as user. Check drive/folder permissions on NAS to make sure it is set as it should be!



  • Since last post I found out, that it is not the admin account as assumed. PA seems to have trouble with special German characters which are used in the UNC path on the NAS. The umlauts (ö,ä,ü) make problems. On other paths with not special letters there seems to be no problem so far.


  • conexware

    What version of Windows do you have and what PA did you use before? It should all be Unicode compliant…

    You can set language for non unicode programs to German in Regional and Language settings in Control Panel, but this should work regardless of that.



  • I am using Win7 x64 Ultimate original german version. I just updated to the latest PA ver. 11.64.01. But the error is still the same.


  • conexware

    can you tell us exactly where you are extracting to (full path), and then turn on that unicode option i wrote about earlier, it should “fix” the issue… thanks



  • The settings for non unicode programs are already set to German (and have ever been). The full path looks like “\server\Öffentlich\Work\Ablage\archive.zip” - then right click on that archive and select “Extract to \ser…\Öff…\Wor…\Abl…\Archive” opens PA, it tries to extract first file from archive and immediately stops with that error “file already in use…” etc.

    First error window:

    Second error window:

    UPDATE:

    Just installed the last working version that didn’t had the problems, it is 11.62.03. Tried it on exactly the same archive as mentioned above - no problems! Extracts perfectly.


  • conexware

    Issue logged in, thanks QBJack!!!


  • conexware

    Please try it with:
    http://www.powerarchiver.com/test/release10/powarc117007.exe

    and let us know if it works better. Thank you!



  • Yes, thank you. Now everything is fine again (as far as I can see in my short test).


  • conexware

    Excellent!


Locked
 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts