Iso mount

  • I am having an issue to mount iso images on my Win 7 x64.

    I am getting the following error message:

    “An error occurred during installation of the device!”

    The same iso file in the same folder can be mounted without any issues on my Vista x64 though so it is not related to the iso file.

    I have the same version of PowerArchiver including PAVD installed on both the machines.

    Any known issues with Win 7 and Virtual drive?? Or any other known issues around this?

    Thank you.

  • conexware

    is it that specific iso or all isos on that computer? There are no similar issues that I know of, a lot more people use PA with Win7 compared to Vista.

  • All iso’s I have tried fail. :confused:

  • Hi,

    I got a post from moles42 about my topic but I cannot see in the forum.

    moles42 was asking this:
    just wondered if you were using any other conflicting virtual drive software on your system?

    Actually it is funny because I am using another virtual drive (UltraIso) on the machine where PAVD is working but I do not have any VD software on my Win 7 machine where PAVD is not working!

    I just tried PAVD on another fresh Win 7 x64 install and it does not work either!!

    So it is working on my Vista Home premium x64
    but not working at all for any iso’s on my Win 7 Ultimate x64 and Win 7 Home premium x64.

    How come? :(
    Are you sure it is working on Win 7 x64??

    FYI, I have been testing the same versions on all my systems i.e. PA 11.62.04 + pastarport13004

    Please help!!

  • conexware

    yes, it works on all of our win7 computers - i am typing this from win7 64bit ;-).

    Can you try deleting pavd2010.exe from PA folder and then reinstalling it again?


  • I have tried this many times but still not working.

  • Alpha Testers

    sorry ‘itechlang’ I did post that question but then deleted it thinking it was irrelevant to your problem anyway…I’ve been searching for a solution to your problem today but upto now still haven’t come up with anything sorry.

    have you tried another piece of software on your W7 system to mount an iso apart from PA?

    and yes it works perfectly on my Windows 7 Ultimate x64 system.

  • moles42,

    yes I tried UltraIso on 1 of my Win 7 systems and it works.

  • Anyone can help? I cannot be the only one having this issue.

  • Alpha Testers

    Far be it from me to promote alternative software but to try and solve this issue can you try using ’
    DVDFab Virtual Drive’ to see if it works on
    your system?

    it works in the same manner whereby you mount the iso files as PA does…
    I’ve just tested it and it works fine on my W7 x64 system.

    apologies to management for seemingly promoting alternative VD software…:o

    what I did like about the program though was when you actually closed it down it removed the virtual drive as well…a facility I did find much to my liking…any chance PA can have this option guys ???

  • Moles42! We might have to beat you for this clear breach in member’s rulling! Now walk away with your head in shame…

    PowerArchiver Rules… “in case management read this”

  • Alpha Testers

    sorry guys…was only trying to help this poor guy out…:o
    give me my 50 ‘lashes’ and let’s move on…:eek:

  • conexware

    After everything PA has done for you Moles……

  • conexware


    All joking aside,
    itechlang, please do let us know the results of using the VD software moles posted and thanks Moles for looking into it!!

    We haven’t had any other reports of constantly failed ISO mounts on x64 so this has to be specific.
    Let’s see how this works

  • Hi guys!

    So I tried DVDFab Virtual Drive as I had tried UltraIso before and both are working perfectly.

    So I am sorry to tell you guys but I am afraid the issue is on your side.

    I have 2 machines running Win 7 x64 and PAVD is NOT working on both.
    I have one running Vista x64 and it is working.

    You must admit it is a weird coincidence.
    For me there is something related to Win 7 x64.

    DVDFab VD and UltraIso are working like a charm on all my machines regardless the OS.

    Hope you will sort this out soon.

  • I have a brand new Win 7 64-bit install here and the PA iso mount works fine. Sorry, I was hoping I could help diagnose your problem :(.

  • conexware

    which windows 7 version do you have installed?

  • Win 7 x64 Home Premium - not working
    Win 7 x64 Ultimate - not working
    Vista x64 Home Premium - working


  • conexware

    maybe there is some software or some option that is common to those two win7’s that dont work?

  • Yes maybe but 1 machine is brand new and the other one is 2 years old and I have never had any issues with other Virtual Drive software.

    How come it is just PA Virtual Drive being not working whereas others like UltraIso, DVDFAb or even PowerIso are working?

    There is probably something on those 2 machines that PAVD does not like, maybe it is the brand. :)
    They are both HP laptops.

    HP Pavilion dv7-3173ca

    HP Pavilion dv9700 CTO
    Unfortunately the HP website has no longer the detailed specifications on this one.

    Thanks anyone for any help with this.

  • Any ideas??

    Anybody else who might have same kind of issue?

    I feel lonely.

  • Are there any logs/traces I can activate and send you guys to help out?

    I still cannot use PA Virtual Drive on both my HP laptops.

    I had also opened a ticket to the support a while ago now but nobody has replied. :(


  • conexware

    Is the ISO file on a local or a network drive?

    as we have an issue reported about mounting ISOs from a network drive

  • I remember trying both local and network and none was working at that time but I just tried again today if I copy ISO files locally then I can mount the images.

    So I would say it is probably related to the network drive issue you are talking about.

    Do you think it is going to be fixed soon?


  • conexware

    well that is great news! I’m glad I asked that question as we now know that the issue is not anything related to your specific system.

    We have this issue(mounting ISOs from network drives) reproduced and reported in our bug system already, not really sure when the issue will be taken care of, the developers will take a look and see what is up. Until then, I hope that mounting ISOs from a local drive will not be too much of a hassle.

    thanks again for the details!!

Log in to reply