PA freezes when a .rar file is missing

  • It has happened quite a number of times now, reason why I want to report this.

    Say you have a set of .RAR files, like:

    You haven’t noticed the missing files.
    Select the first one, rmb extract to \bla bla-folder

    PA start and reports a missing file.

    Then I donot want PA to continue, because I wanna fix that file first.

    So I hit cancel.

    PA stops, but after that nothing happens, PA just freezes, hourglass…
    After a few minutes I need to kill it using the taskmgr.

    PA v.11.61.07 12/2009

    Will there be a fix : cancel means cancel+close down PA and not hang itself??


  • conexware

    this has been reported before, definetly will be looking into it for one of the future minor releases…

  • @spwolf:

    this has been reported before, definetly will be looking into it for one of the future minor releases…

    Thanks a lot!

  • Have to confess, haven’t tried this out yet, because sofar there was no reason for it, but has his been fixed?

  • conexware

    Testing an internal version of the next update and it seems to have been fixed.


  • When will the next update come where this is fixed?
    When I start to extract an incomplete set, PA reports it is incomplete, but cancel will NOT stop PA from extracting.
    It stumbles accross the missing .rar and hangs.

    : which takes a while as PA ‘does not respond’ - in the end it closes indeed though,

    I need to kill it using the taskmgr… which is quicker.

    (and also need to clean up the stuff PA already extracted)


  • conexware

    can you please check this with 11.63, we can not reproduce it anymore… just making sure.


  • Sorry for the delay …

    and eh …

    sorry but it has not solved yet (at least not with me)

    Just downloaded a .rar set, extraction went fine.

    Then I renamed .rar to r__ of one of the files.
    Then RMB extract
    PA reports one is missing, click CANCEL (!), and it continues (I donot want it to continue…)
    in the end it hangs and I am using the taskmgr to kill it.

    Regretfully I cannot get you a printscreen of the point at which PA hangs (why I try to make a printscreen, SnagIt closes)

    Suggest to give it a try.


  • conexware

    what version of PA and Windows?

  • PA 11.63.13 (07/2010)
    W7 Ult 64bit

  • conexware

    thanks wulffra, looking into it again!

Log in to reply