Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

RAR: Adding missing file



  • 1. create a spanned archive. (.part01… .part04)
    2. move the latest file to a different folder.
    3. extract archive. It will ask for the .04 file
    4. move file to .04 file to the proper folder
    5. press ok

    PA is now asking for another file. Which there isn’t

    Tested this on 61.01


  • Alpha Testers

    you run some very strange scenarios 'guido but very effective indeed…:)



  • @moles42:

    you run some very strange scenarios 'guido but very effective indeed…:)

    it looks like a strange scenario. But I was extracting while some files still had to be downloaded. During extraction the missing file was added.



  • just for fun. Try the same thing with & in the filename.


  • Alpha Testers

    up to now I haven’t been able to reproduce your first report but I will test again before conceding defeat…:)

    I still can’t get this to happen…tried with several sized spanned archives.
    firstly I created an archive with 34 parts to it and placed part 34 on my desktop and then obviously asked for part 34 whilst trying to extract…I replaced the missing part and told it to continue and it did without any faults at all…also tried removing one of the middle parts of the archive and it too worked fine.

    the only problem I did encounter was when trying to do this via the context menu and not the main GUI…
    I was hit with a ‘Not Responding’ message after replacing the missing part.

    so either I’m not having this issue or I’ve done something wrong…😕

    also tested on v11.61.01


  • conexware

    we got it…


  • conexware

    Here you go:
    http://www.powerarchiver.com/test/release10/powarc116104.exe

    let us know if it has been fixed. Thanks!



  • Not fixed. still get the message "insert volume 2 c:\windows\system32\E

    Also my progressbar says current file: E
    I must remind you this is windows 7 x64



  • this is the error I get when I put one file back, but the next file is missing.
    attachment_p_20819_0_extract.png


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.