Extracting and relative paths


  • Banned

    Could you briefly explain the mechanism for extracting multiple files which are stored with RELATIVE PATHS?

    I am copying files from one computer to another; since my username is not the same on the two computers, the foldername under “Documents and Settings” differs.

    In PA 11 this seemed to work fine. But I have had troubles with the last three versions.

    Perhaps I am just doing something wrong.


  • conexware

    Extracting always works the same, no matter if you used relative or full paths during extraction. So if your username has been saved under path, it will be extracted if all files are selected for extraction.

    You can turn on explorer view mode, and select specific folder for extraction. So go to your documents folder inside archive and then select files inside that folder, and they will be extracted with that folder as starting path.

    I hope that made sense…


  • Banned

    Initially it DID work for me in PA if I choose the extract button and then selected my own folder. It did not work if I selected the same folder from the drop-down list.

    Then it was fixed so it worked both ways in PA.

    Then one of two versions later, it would not work. Still doesn’t work 3 RCs later.

    It works flawlessly if I use WinZip.

    I will wait for a couple of months until the final 11.6 version is out and has been refined and give it a whirl.


  • conexware

    You do not understand.

    It is not the selection of extract folder location.

    You need to select folder from inside archive from where you want PowerArchiver to start extracting paths.

    So turn on explorer view and go inside My documents folder in that archive and then select files there to be extracted. They will be extracted with path relative to the folder where you are in the archive.


  • conexware

    or maybe you want that during compression paths are stored differently, in that case, you need to check options for storing paths during compression.


  • Banned

    I realize there are two things you have to do. I selected the path from within the archive that I want to extract. I also have to select to where the files will be extracted (I assumed that is what the extract button and the extract drop-list are supposed to allow me to do).

    It worked just fine in one of the earlier version. It worked just fine with WZ.

    Again, I will just wait.

    suggestion. I case it is just a different way of doing it rather than a glitch, I would propose you post a series of screen shots in your support area which (a) walk a person through the precise ways of building an archive and (b) the precise ways of extract them from the archive.

    Oh, and if relative paths made no difference, which include them both in the configuration settings (“normal” relative paths AND in the windows for creating a backup script.

    In any event, I will wait and see.


  • conexware

    those options are for creation of paths during compression, not during extraction (you can also check help in Add window to see how different path options work)… there is an option though to ignore paths (no paths) during extraction, but thats in extract window.

    Can you please tell me what did you select to extract and what got extracted? Because it works fine here. But I have feeling that we are talking about different things.


  • Banned

    Let me try one more time.

    I (want to) use backup scripts to move files from my home computer to my work computer. Specifically, I want to copy a number of files from my Documents and Settings directory from home to work.

    Since my username (Documents and Settings\username) is different on the two computers, I set the backup script to save only relative paths, not the full path.

    The plan is to take the archive to work, and extract the files into my D&S folder there.

    When I first tried using PA, I COULD extract the files under one condition. (1) I opened the archive, drilled down through the D&S folder, then the homeusername folder until the relevant sub-folders (Applications, Local Settings, and My Documents) were in the right side of the explorer window. I then selected those files, clicked on the Extract button, browsed to the workusername folder, and then clicked “extract.”

    However, I could NOT, on subsequent uses, choose the workusername folder from the drop down menu associated with the extract button. Well, I could choose it. But it did not extract the files to the proper folders.

    I pointed out the problem, and in the next version, I could get the files to extract, BOTH ways — from the extract button and by using the drop down options. That is what I want.

    By the next version, the problem reverted.

    Now I cannot get the files to extract to the right folder EITHER WAY.

    With WinZip, the extract is simple. No problems. So I am stuck using PA to build the transfer file; then I have to use WinZip to extract the files.

    Is there is some new secret for extracting files from an archive?


  • conexware

    where do they get extracted?

    For instance if in archive, go inside my documents path, select all files, then click extract and select my documents folder in your computer - what happens?

    I have tested it, and it correctly moves files when I tried it (it disregards paths above my documents in archive).


  • Banned

    With PA they get extracted to a documents and settings folder that PA creates within the workusername directory.

    With WZ they get extracted to the proper folders.

    For a while in a beta version of PA they also got extracted to the proper folders.


  • conexware

    do you mind sending us an screenshot of:
    a. what you select in PA (in archive),
    b. what folder you select for extraction in extract window
    c.extracted folder in PA explorer or Windows explorer (extraction results).

    I apologize for extra work, but i want to make sure we are doing same things so we can reproduce it.

    thank you!


  • Banned

    Sorry. I have already spent more time on this over the past two months that I dare count. More time than I could afford.

    I will continue to use WZ to extract and wait and see if this is fixed soon.


  • conexware

    @Socrates:

    Sorry. I have already spent more time on this over the past two months that I dare count. More time than I could afford.

    I will continue to use WZ to extract and wait and see if this is fixed soon.

    it probably wont be fixed until someone shows us how to reproduce it, so i guess we will repeat this over and over 🙂


  • Banned

    I won’t.

    PA is gone.

    Please remove me from the forum.


 

9
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy