PowerArchiver 2010 Problem



  • I have been using the Traditonal Chinese version of Powerarchiver 2007 previously and apart from being a bit slow sometimes, the program presents no problems.

    I just installed and tried Powerarchiver 2010 Traditional Chinese version in the Traditional Chinese version of Windows XP SP3 and have encountered a serious bug. Whenever I attempt to create a zip archive containing files with Chinese file names, the program would simply hang and I have to use Task Manager to kill it.

    The English version of Powerarchiver 2010, on the other hand, apparently does not have this problem. It can create archives with files having Chinese file names without problems. And of course Powerarchiver 2007 never had this particular problem. So the only conclusion that I can draw is that there is a problem with the Traditional Chinese version of Powerarchiver 2010.

    This is a pretty crippling problem and for now I have uninstalled Powerarchiver 2010. Even with new multicore support, this bug essentially makes the program useless to me.

    Can anyone confirm if this is indeed a bug in the TC version of Powerarchiver 2010? I would like to hear from the Powerarchiver developers in particular. If this is indeed a bug I would expect a patch soon.


  • conexware

    is it with English version too? Try creating chinese archives with english version…


  • conexware

    what version of PA 2010 were you using? And please explain exactly on how do you get the issue.

    thanks!



  • @ivan:

    is it with English version too? Try creating chinese archives with english version…

    As I have stated, the English version of PA 2010 apparently does not have this problem. But you can understand that I would prefer to use the Traditional Chinese version under the Traditional Chinese version of XP SP3. After all that is why you release the Traditional Chinese version, correct?

    @spwolf:

    what version of PA 2010 were you using? And please explain exactly on how do you get the issue.

    thanks!

    As I have already stated, I was using the Traditional Chinese version of PA 2010 (11.50) downloaded from this site. I just attempted to create a new zip archive in PA 2010 using the New button and then add several files with file names in Chinese. That was where the program hanged and had to be terminated using the Task Manager. This problem means the Traditional Chinese version of PA 2010 is essentially uselss to me at this time.

    The Traditional Chinese version of PA 2007 (10.22) and PA 2009 (11.03) do not have this problem.


  • conexware

    @James:

    As I have stated, the English version of PA 2010 apparently does not have this problem. But you can understand that I would prefer to use the Traditional Chinese version under the Traditional Chinese version of XP SP3. After all that is why you release the Traditional Chinese version, correct?

    As I have already stated, I was using the Traditional Chinese version of PA 2010 (11.50) downloaded from this site. I just attempted to create a new zip archive in PA 2010 using the New button and then add several files with file names in Chinese. That was where the program hanged and had to be terminated using the Task Manager. This problem means the Traditional Chinese version of PA 2010 is essentially uselss to me at this time.

    The Traditional Chinese version of PA 2007 (10.22) and PA 2009 (11.03) do not have this problem.

    that is not enough information for us to determine the issue, this is what i need:
    1. install latest PA 2010 from our site
    2. Check if version in Help> About is 11.50.66
    3. Give us step by step on what exact archive did you create (filename) and example chinese filename that you tried to compress.
    4. we need to know what format you used and what options for that format.

    With that we can try to reproduce the issue and then fix it.

    thanks!



  • @spwolf:

    that is not enough information for us to determine the issue, this is what i need:
    1. install latest PA 2010 from our site
    2. Check if version in Help> About is 11.50.66
    3. Give us step by step on what exact archive did you create (filename) and example chinese filename that you tried to compress.
    4. we need to know what format you used and what options for that format.

    With that we can try to reproduce the issue and then fix it.

    thanks!

    I have reinstalled the Traditional Chinese version of PA 2010 (11.50.66). I am using the Classic interface.

    I created a new ZIP archive called “Test” by clicking on the Add ( 新增 ) button. Then I attempted to add a file called “風流逍遙神.txt” to the archive. I used the default options for ZIP files without changing anything, such as compression methods and speeds.

    The program hanged.

    As you may imagine, I am definitely not very happy about this situation. I was looking forward to upgrading to this version because of the multicore support. But now it seems I will have to wait.

    Or, can I use the English version of PA 2010 in other language versions of Windows XP/Vista to create ZIP archives with non-English file names or add files with non-English file names?


  • conexware

    @James:

    I have reinstalled the Traditional Chinese version of PA 2010 (11.50.66). I am using the Classic interface.

    I created a new ZIP archive called “Test” by clicking on the Add ( 新增 ) button. Then I attempted to add a file called “風流逍遙神.txt” to the archive. I used the default options for ZIP files without changing anything, such as compression methods and speeds.

    The program hanged.

    As you may imagine, I am definitely not very happy about this situation. I was looking forward to upgrading to this version because of the multicore support. But now it seems I will have to wait.

    Or, can I use the English version of PA 2010 in other language versions of Windows XP/Vista to create ZIP archives with non-English file names or add files with non-English file names?

    I am testing on our Win XP Traditional Chinese edition and that seems to work fine.

    What happens if you click on New and then create new archive, same?



  • @spwolf:

    I am testing on our Win XP Traditional Chinese edition and that seems to work fine.

    What happens if you click on New and then create new archive, same?

    Yes, it hangs. By the way, I should have said that I created the ZIP archive by clicking the New button, not the Add button. The ZIP file cannot be created (as the program hangs) and therefore it is not possible to see if the Add functionality works or not.


  • conexware

    @James:

    Yes, it hangs. By the way, I should have said that I created the ZIP archive by clicking the New button, not the Add button. The ZIP file cannot be created (as the program hangs) and therefore it is not possible to see if the Add functionality works or not.

    maybe it has something to do with
    a. folder where you are storing archive
    b. temp folder

    maybe try changing these to some other folder like C:\1 and then see if that might be the reason for the problem.

    thanks!



  • @spwolf:

    maybe it has something to do with
    a. folder where you are storing archive
    b. temp folder

    maybe try changing these to some other folder like C:\1 and then see if that might be the reason for the problem.

    thanks!

    No use, still hangs.

    Also, if you succeed in creating the archive, delete it and try to create it a second time. It always fails in my case and the program hangs even if the first time is a success.

    I am going to uninstall PA 2010 and reinstall PA 2009 if there is no fix coming soon. I cannot wait indefinitely.

    By the way, I read from another thread here that 11.51 may be released soon. Is that correct?


  • conexware

    @James:

    No use, still hangs.

    Also, if you succeed in creating the archive, delete it and try to create it a second time. It always fails in my case and the program hangs even if the first time is a success.

    I am going to uninstall PA 2010 and reinstall PA 2009 if there is no fix coming soon. I cannot wait indefinitely.

    By the way, I read from another thread here that 11.51 may be released soon. Is that correct?

    aha, when i did it 2nd time it hanged as well… :).

    We always release new versions relativly soon, so we will probably release fix for this soon as well :).

    We will let you know via this forum thread. Thanks for reporting it!



  • @spwolf:

    aha, when i did it 2nd time it hanged as well… :).

    We always release new versions relatively soon, so we will probably release fix for this soon as well :).

    We will let you know via this forum thread. Thanks for reporting it!

    Good. So it is confirmed as a bug.

    By the way, I suggest you test this on the Simplified Chinese version as well. I tried it myself and it seemed to hang also. If you need to fix the problem you may as well fix all language versions affected by this problem.


  • conexware

    @James:

    Good. So it is confirmed as a bug.

    By the way, I suggest you test this on the Simplified Chinese version as well. I tried it myself and it seemed to hang also. If you need to fix the problem you may as well fix all language versions affected by this problem.

    only difference between all international versions is just language file, everything else is the same… so bug should be present in every other language (maybe not in german) with those same specific settings.


  • conexware

    Hi,

    please check following release:
    http://dl.powerarchiver.com/2010/powarc1160rc1.exe

    and let us know how it works now.

    thanks!

    p.s. this is english version for now, but please test it anyway as issue was present in all PA versions.


  • conexware

    Hi,

    you can download PA 2010 Preview 11.60.10 release (TC language) from our web site or via web update.

    It contains several updates that make it work better with Chinese Windows XP.

    Please try it now and see if it works properly.

    thank you!


  • conexware

    Nothing from Agent 007 yet I see 🙂



  • I have downloaded the Traditional Chinese version of the PowerArchiver 2010 11.60 Preview (11.60.10) from the download section of your website. And my preliminary tests show that the previous bug I reported has apparently been fixed.

    If there are any problems with this version I will let you know.


  • conexware

    @James:

    I have downloaded the Traditional Chinese version of the PowerArchiver 2010 11.60 Preview (11.60.10) from the download section of your website. And my preliminary tests show that the previous bug I reported has apparently been fixed.

    If there are any problems with this version I will let you know.

    thank you!

    I am closing this, if you find anything else, open up new thread…


Locked
 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts