PA2010 dropping Readonly attribute

  • Don’t know if this is a bug or I have maybe just got bad settings, but since I switched to PA2010 extracted files no longer have the Readonly attribute when it was there on the original file. This is critical for me in one particular usage where I need to preserve the Readonly attributes for all files in a large nested diretory archive. This was fine on PA 2009 - I am using latest RC of PA2010 on XP.


  • Could you write what method of compression you’re using? I just checked with 7z (optimized), and it works fine for me

    Edit: Oh, yeah, now I see what you mean. Tried both .zipx (again, optimized and ultra) and .cab (maximum), and I can confirm that the read-only attribute isn’t saved. Still does on .7z, though.

  • conexware


    please check updated/latest release from today:

    this should work fine now, please check it out.


  • Now it works for me on all archive types except TAR (and it doesn’t work for all 3 TAR methods).
    I should mention that I didn’t try every method in every archive type, just those of TAR (because the first didn’t work). For the others, I used the best configuration. I don’t know if that matters.

    Perhaps realj42 can tell us if it works for him now, as well.

  • conexware


  • Beautiful - works a treat for me now. Thanks for a quick turnaround on that one.

Log in to reply