Problems with unicode zip in PA 2010 RC



  • I am using Power Archiver 2010 RC3 and I have a problem displaying Unicode for zip files. 7z and Rar files seem to be okay. I am using Windows 7 RC.

    I have attached several zip files to show what I am talking about:

    Test1_(7-zip).zip - [i]A zip file compressed by 7-Zip[/i]
    Test1_(PA).zip - [i]A zip file compressed by Power Archiver[/i]
    Test1_(PA).7z - [i]A 7z file compressed by Power Archiver[/i]
    Test2_(7-zip).zip - [i]A zip file compressed by 7-Zip[/i]
    Test2_(PA).7z - [i]A 7z file compressed by Power Archiver[/i]
    
    

    I have also posted screenshots of what Power Archiver displays when it opens and extracts the said files.
    http://www.picamatic.com/view/3985786_Test_1_Results/
    http://www.picamatic.com/view/3985787_Test_2_Results/

    Thanks for the great program- this is really the only issue I have with it (and it worked fine in PA2009).
    attachment_t_3858_0_test1_-7-zip.zip
    attachment_t_3858_1_test1_-pa.7z
    attachment_t_3858_2_test1_-pa.zip
    attachment_t_3858_3_test2_-7-zip.zip
    attachment_t_3858_4_test2_-pa.7z



  • One more thing - I want to add the original folders and the extracted files (extracted by Power Archiver) to give you a clearer picture.

    They are inside a .7z file, so the Unicode (and corrupted Unicode) should stay intact.

    Edit:
    Oops, I am actually using RC2. I will try RC3 to see if the issue is solved.

    Edit2:
    No, the results are still the same.

    In addition, checking or unchecking “Use OEM” and “Force Unicode in Zip” or any combination of the two does not seem to make a difference for the specified files.
    attachment_p_18973_0_test_folders_and_extracted_folders.7z


  • conexware

    did you try unchecking “use oem…” ? Any difference.

    two things:
    1. excellent report :).
    2. always open new threads as it is easier for us to track problems.

    thanks a lot!



  • No, nothing in the configuration menu was able to fix my problem. I will check 2010 RC2 on Windows XP to see if it works, since I am certain 2009 works on XP.



  • OK I’m back. I did a few tests.

    First I changed my regional setting back to US from Japanese in Windows 7. I was able to archive and extract unicode files perfectly. However, when I tried to display or extract the zip file I had created earlier (while in Japanese regional setting), I was unable to. Even with 7-Zip, the unicode was corrupted.
    (See Comparisons)

    I have uploaded two zip files:
    [u]Test1 (7-zip) JP.zip[/u] - Archived while in Japanese regional settings (in regional settings in Windows 7 control panel)
    [u]Test1 (7-zip) US.zip[/u] - Archived in US settings
    

    In XP, extracting “Test1 (7-zip) JP.zip” with PA2010 gave unusual results where the file extensions were corrupted, while the names retained some unicode (see pic). I was able to extract “Test1 (7-zip) US.zip” perfectly fine.

    I uninstalled 2010 and installed PA2009 (11.03).

    While in Japanese regional setting on XP, I was able to display/extract unicode files with PA2009. “Test1 (7-zip) JP” extracted and the unicode filenames were correct. “Test1 (7-zip) US” extracted but the unicode filenames were converted to Japanese letters (checking/unchecking “OEM conversion” did not make a difference). PA2009 could not display any unicode (See pic)

    Extracting a unicode directory (“Test2 (PA) JP XP.zip”) resulted in an error (see pic).

    –------

    What I get from this is that if you both compress and extract archives while in US regional settings, you will be fine. However, if you download files from other parts of the world, unicode may not display correctly. With PA2009, most unicode did display correctly in any circumstances. There are only problems if it can’t read the directory.
    attachment_p_18976_0_test1-7-zip-jp.zip
    attachment_p_18976_1_test1-7-zip-us.zip
    attachment_p_18976_2_test2-pa-jp-xp.zip


  • conexware

    I believe problem is that it is not saving them in Unicode at all :).

    You see PA tries to determine when to use ANSI and when to use Unicode - it tries to use ANSI when possible because Unicode is not supported in most archivers, and Unicode when ANSI is not possible.

    It seems that something is wrong there - devs will take an look… thanks a lot! Perfect timing too!


  • conexware

    Hello,

    Thanks for the detailed info.
    First of all I am using USA as my regional setting.
    I am sure some of issues from first post were solved in RC3 because we were working on it.

    Test1 (7zip).zip was definetelly created wronly by 7ZIP (other utilities show same errors or wrong filenames).

    test1 (PA).zip has wrong characters but I was able to create it using right click on Test1 folder and choosing “Compress to test1.zip” correct file.

    Test2 all procedures - including creating a test2.zip from shell using PA (Compress to test2.zip) worked fine.

    So all issues should work fine. test1 created with 7z is wrong in any way.

    Can you try creating some archives using those files from main interface - not shell extensions?


  • conexware

    Please check this release:
    http://www.powerarchiver.com/test/alpha115/powarc1150rc3.exe

    see if that works properly.

    thanks!


  • conexware

    I have tested RC3 too, and seems like it works fine - please let us know when you have an chance. thanks!


 

7
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy