Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Problem with relative path in PBS



  • I’ve created a PBS to archive (to a ZIP) all files in a folder and its subfolders. In the PBS, ‘Store relative folder information (not full location)’ is turned ON. The folder looks like this, conceptually:

    folder
    –file1
    –file2
    –file3
    –subfolder
    ----file4
    ----file5

    What I want is for the ZIP file to contain this:

    file1
    file2
    file3
    subfolder
    –file4
    –file5

    But instead, the ZIP file contains this:

    folder
    –file1
    –file2
    –file3
    –subfolder
    ----file4
    ----file5

    I’ve run this PBS both when the ‘Use normal relative path’ setting in PA itself is turned OFF and ON, and the result is the same.

    Is there any way I can get the PBS to do what I want?

    FWIW, when I use PA to create this ZIP “manually,” the ‘Use normal relative path’ DOES make a difference. When it’s OFF, I get the result I want. When it’s ON, the root folder gets stored in the ZIP. But that setting does not seem to affect PBS-created ZIPs.

    Jeff Jansen

    Addendum: The same problem occurs even when the folder has no subfolder. Correction from original in red.


  • conexware

    i guess we can apply same option as in main pa for relative paths.



  • Great! So are you saying that will go on the list of changes to make?

    Jeff


  • conexware

    we will take an look, but you do understand that this will work if you have only single folder aded? Just like in main PA.



  • Actually, I find that the PBS does not work even if I have only a single folder added.


  • conexware

    @jsjansen:

    Actually, I find that the PBS does not work even if I have only a single folder added.

    dont work?



  • By which I meant to say:

    When I:

    1. have this file structure:

    folder
    –file1
    –file2
    –file3

    1. Configure PA with ‘Use normal relative path’ OFF

    and

    1. Create a PBS to backup ‘folder’ with ‘Include subfolders’ ON or OFF, and ‘Store relative folder information’ ON,

    then the resulting zip file contains this:

    folder
    –file1
    –file2
    –file3

    and not this:

    file1
    file2
    file3

    Jeff Jansen


  • conexware

    @jsjansen:

    By which I meant to say:

    When I:

    1. have this file structure:

    folder
    –file1
    –file2
    –file3

    1. Configure PA with ‘Use normal relative path’ OFF

    and

    1. Create a PBS to backup ‘folder’ with ‘Include subfolders’ ON or OFF, and ‘Store relative folder information’ ON,

    then the resulting zip file contains this:

    folder
    –file1
    –file2
    –file3

    and not this:

    file1
    file2
    file3

    Jeff Jansen

    yeah, of course - it does not respect that option right now. I was just commenting that in the future, only difference would be exactly that situation that you are commenting 🙂


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.