Please Notice: For fastest support from PowerArchiver team, contact us via our Support page

Incorrect Temp folder on PA 2009 Pro



  • PA2009Pro 11.03.04, WinXPSP3
    My disk divide to C: (FAT32), … I: (NTFS),
    Temp folder SET to I:\Temp (Options>Cofiguration>Folders>Temp Location:C:\Temp)
    (Options>Cofiguration>Miscellaneous>Speed>Use current folder as temp is unchecked)
    When I’m creating backup PA ALWAYS! used C: …, don now exact directory, but on the C:.
    Why? And because fail is larger >2GB, PA crashes and can’t create fail.
    How change temp folder to I:???

    PS.Problem is when backup fail is ZIP. With 7Zip there is it NO??? Temp fail. Backup fail is on the destinations and increase with progress of compressing.



  • Sorry but your decsription is a bit confusing; I hope you don’t mind if I ask some questions to clarify …
    @Stefiff:

    My disk divide to C: (FAT32), … I: (NTFS),

    So I: is a partitionj on the hard disk (not different disk)?
    @Stefiff:

    Temp folder SET to I:\Temp (Options>Cofiguration>Folders>Temp Location:C:\Temp)
    (Options>Cofiguration>Miscellaneous>Speed>Use current folder as temp is unchecked)

    Is that a typing error? Should be (Options>Cofiguration>Folders>Temp Location:I:\Temp)
    @Stefiff:

    When I’m creating backup PA ALWAYS! used C: …, don now exact directory, but on the C:.

    What files are you backing up - could the activity you see be PA reading the files?
    How are you performing the backup?
    Have you tested by making test archives?
    Where is the backup archive being stored?

    If you are using a backup script, could you list it or even provide it?
    @Stefiff:

    And because fail is larger >2GB, PA crashes and can’t create fail.

    I guess you mean “file” and not “fail”?
    When PA crashes, is there any error message(s)?
    Do you have less than 2GB free on C:?
    How much free space on I:?
    What is total size of files you are backing up - BEFORE compressing?
    @Stefiff:

    PS.Problem is when backup fail is ZIP. With 7Zip there is it NO??? Temp fail.

    Is this using PA to create 7Zip archive or do you mean using the 7Zip utility itself?
    @Stefiff:

    Backup fail is on the destinations and increase with progress of compressing.

    Sorry, I don’t know what you are saying here 😕


  • conexware

    what format are you using?


  • conexware

    so you are using zip and you have issue, with 7z no issues.



  • Sorry for bad English, it is not my natural language.

    1. One disk. C:,D:,E:,F:G:H:,I: - 500GB Seagate SATA2.
    2. Typing error. Correct is …I:\Temp.
    3. My source files is on the 😨 - F: - documents. All windows is closed, no activity. PA reading file OK.
    4. When resulting/ backup/ file is smaller than <2GB, everything is OK. No problem with creating, testing, saving file. Creating: Backup>Create/Edit ……
    Tested
    with ZIP and 7ZIP/ with PA/,
    Type: normal and incremental,
    Compression: Normal and Maximum.
    Destination Media>My Computer>”H:\” - local and ”\dlinkhdd\Volume_1\k3_data”- network storage,
    Scheduling Options >”Once a week”,
    Starting Backup with “Do Backup” and with Windows Job.
    6. Disk C: is 35GB, free 23GB, G: is 70GB, free 65GB, H: is 70GB free 54GB, I: is 67GB free 62GB. There is no problem.
    7. Here is sample script:

    [General]
    Archive=H:\k1.zip
    TimeStamp=1
    TimeStampText=-M-D-H-m-S
    TimeStampMode=0
    ScanArchive=0
    Overwritef=0
    AddQueue=0
    AddLocal=1
    AddLocal2=0
    AddLocal3=0
    LocalDir2=
    LocalDir3=
    IncludeSubFolders=1
    IncHidden=1
    Compression=1
    Action=2
    EPassword=yrYbhwK2M2MURJzpHRFjdQ==
    EncPassword=1
    RelativeFolderInfo=0
    ShowDone=0
    RunSilent=1
    RunSilentMode=2
    GrowZip=0
    UseOptimized=1
    AddArchiveBit=1
    AddSolid=1
    ResetArchive=1
    UseSpanning=0
    TestArchive=0
    LogToFile=0
    LogFile=D:\MyDocs\Backups\Logs%backupscriptname%.txt
    EmailLog=0
    Encmode=0
    Hidepassword=1
    [CD]
    BurnArchive=0

    FtpArchive=0
    FtpLimit=
    Directory=

    eMailArchive=0
    Smtp=mail.stivi.eu
    Port=25
    To=stiviapp@stivi.eu
    From=backup@stivi.eu
    Text=Please find logs of the %backupscriptname% attached.
    Subject=%backupscriptname% backup log

    [Files]
    F1=G:\ImageInstal\ADOBE.CREATIVE.SUITE.PREMIUM.EDITION.V2.0-TDA
    [FileTime]
    FTMode=0
    FTDays=0
    FTHours=0
    FTMinutes=0
    FTDate=931201024
    [FileSize]
    FSMode=0
    FSSize=0
    FSSizeMode=1
    [Schedule]
    Mode=2
    Time=25
    Days=

    8. Tested on second computer with same options – result is the same, error.
    9. PA STOP creating Backup file / when size reached 2GB/ with “ Disk full or you have no permission to write …”. No Crash! Simply STOP.
    10. I’m checking disk space / on 10 sec/ to determine which drive is using for temp location
    when creating backup file.
    With ZIP temp location is “C:\Documents and Settings’User name’\Local Settings\Temp\” z853548(file) – always this location!!
    With 7Zip NO temp file. Only resulting/backup file ON THE destinations and increase / checking on 10 sec/ to it is final volume.I.e no copy operations, no need.

    My Idea is to backup some files on the NAS / dlink-323/. PA creating backup file, and when file is <2GB, everything is ok. Creating temp file on “C:\….” then copy to NAS”\dlinkhdd…”. But when temp file is >2GB and type is ZIP, PA stopped when file reaches 2GB.
    I’m not tested with 7ZIP and network destination, only local. Computers are on my office, but now I’m writing from home.



  • @Stefiff:

    Sorry for bad English, it is not my natural language.

    That is not a problem - I just didn’t want you to be upset when I asked all those questions 😃

    To me, your settings should be OK, so you appear to have identified two separate problems/bugs:
    a) Changing Temp folder
    b) 2GB file size limit on zip compression

    Note: PA zip used to have a 2GB limit but this was increased in an earlier version (PA8 or PA9).

    P.S. might be a good idea to remove the email addresses in the your post to avoid “bot/spam scanners”


  • conexware

    problem is maximum size of single file - 2 GB under FAT32 (that has nothing to do with zip or any other format).

    It means zip backup is not using specified temp path, but always uses C:…. this might have been fixed in upcoming version already, but we will check it and make sure in any case.

    thanks!



  • I’m do some test.

    Sorry for me. 😞

    Checked on 3 computers, with WinXP/SP2, WinXP/SP3. Result is the same. I’m know 2GB limit for FAT32.
    Problem is that I can’t move temp file to NTFS partition:(.

    Checked with 7ZIP, local and on the network. Result is the same. NO temp file, when PA creating backup file. I’m think it is not good idea when backup file is big and moved on the network some times >10 min.

    ZIP.
    PA using “TMP” Environment Variable from Windows!! When I’m changed “TMP” and temp file location moved on new location:D. When I’m changed “TEMP” Environment Variable from Windows, temp file not move. / Control Panel>System>Advanced>Environment variables>User variable for “USER”>TMP;TEMP /

    Email.
    I’m not using because it is not work for me:(. On Outlook Express I’m using “ My server requires authentication” from Account. My SMTP server is MY, where hosting my account. It is different from server on my Internet Provider. In PA there isn’t option like this.

    Sorry for me. 😞


  • conexware

    can you please try with PA 2010 Beta 1 Preview? If you are Pro user, you should have gotten it in email.

    thanks,



  • Checked with PA 2010 :(.
    Same bug.
    PA loading “TMP” variable on starting “POWERARC.EXE”. When I changed variable after starting PA, temp folder not changed.
    The worst of it is that: PA 2009 checked destination, if it exist, by creating file with zero length on it. PA 2010 not check this :(.


  • conexware

    wait - so problem is that you changed destination after load of PA?

    It works if you restart?


  • conexware

    or do you mean that it doesnt save the change?


  • conexware

    backup is now different from PA, so you have to exit PA for the settings to be saved.



  • So…
    PA2010 installed over PA2009.
    Before start PA 2010:
    “TMP” from WinXP set to “%USERPROFILE%\Local Settings\Temp” by default.
    “Temp Location” from PA 2009 set to “I:*”.
    1. Start PA2010, Check “Temp Location”, same - “I:*”. Close PA2010.
    For ZIP.
    2. Start PA2010. Click Backup>….pbs. Check settings , everything is OK. Click “Do Backup”.
    3. Check temp file while PA working. Created in “TMP” location = “
    %USERPROFILE%\Local Settings\Temp**”.
    4. Close PA 2010!!. Change “TMP” to “I:\temp”. Repeat step 2.
    5. Check temp file while PA working. Created in NEW “TMP” location = “I:\temp”. !!
    6. Close Backup window!!. PA not closed.
    7. Change “TMP” to “D:\temp”. Click Backup>….pbs. Check settings, everything is OK. Click “Do Backup”.
    8. Check temp file while PA working. Created in OLD “TMP” location = “I:\temp”. !!

    For 7ZIP – no temp file, checked.


  • conexware

    So the problem is that in Backup “Temp” location is not used the same as defined in Configuration of main Pa WIndow (Options -> Configuation -> Folder)?

    If this is your problem, it will be fixed in next release.



  • Yes!
    I can’t change it.
    Because on all my clients with WinXP, “C:” is formatted with FAT32 / it is easily fight with viruses /. And I can’t create backup:(.


  • conexware

    Ok. Sorry for inconvinience that caused to you. We always suggest not to use beta for work environment, but new beta will come really soon, and hopefully solve the issue.


  • conexware

    please check with official beta 1, and let us know if this has been fixed… thank you!


Log in to reply
 

Looks like your connection to PowerArchiver Forums was lost, please wait while we try to reconnect.