Daemon.dll not found



  • Hi. Since I’ve removed my old (and registered) copy of Daemon Tools to replace it with the latest version of Deamon Tools Lite, PA now display the following error message multiple times (tens of times) at startup and whenever I navigate to another repertory: 😞

    Error Message title- “Powerarc: POWERARC.EXE - Unable To Locate Component”

    Error Message text- “This application has failed to start because daemon.dll was not found. Re-installing the application may fix this problem.”

    Obviously, PA is no longer able to find the library daemon.dll which is now located in the repertory “Daemon Tools Lite”. I tried to add this repertory to my path as described in http://www.powerarchiver.com/forums/showthread.php?t=1311&highlight=daemon but with no luck. Also, if I try to copy this library and the library imgengine.dll in the PA repertory, PA does not work anymore at all (it completely freezes, with nothing useful displaying).

    I’m using the standard version of PA, version 11.03.04 (registered) on WinXP Pro and I’ve not found where to specify the location of Daemon Tools to PA. I’ve also tried to disable the association with the .ISO and .BIN, IMG and .NRG images file formats but with no luck.

    Any idea? 😕 Thanks.


  • conexware

    Virtual Drive uses same drivers as Daemoon tools, but if you are not using VD, I really cant see what could cause the issue - all those drivers are loaded on the need basis in any case, and not automatically.

    Did you try reinstalling PA?



  • Yes, I’ve tried to reinstall (and to repair, too) PA. I don’t use VD because I’m using the standard version of PA; so I don’t understand what deamon.dll is doing in the picture. This problem appeared right after I replaced Deamon Tools (a very old version) with Deamon Tools Lite in order to see the same thing as one of my client.

    The next step that I will try will be probably a complete desinstallation of Deamon Tools Lite and its reinstallation in the Deamon Tools repertory (instead of Deamon Tools Lite) and the same thing with PA; however, I really don’t understand what Deamon.DLL is doing here as I don’t use VD at all.


  • conexware

    i will have dev team check it out as well…


  • conexware

    did you find out anything new?



  • the problem could be down to a registry program or the person could be using a cracked version of powerarvchiver.



  • No, I’m not using a cracked version of PowerArchiver and I don’t even see why you could think of this as a possible reason for the aforementionned problem.



  • @spwolf:

    did you find out anything new?

    Sorry but I didn’t have the time to make a serie of tests yes (ie., to remove these programs and start reinstalling them in various orders/versions).



  • Hi, just a word to tell you that I’ve been able to repair my installation of PA by removing it, removing Daemon Tools Lite (DTL) and then reinstalling PA but without reinstalling DTL first (reinstalling it only after PA).

    Trying to repair or to reinstall PA while DTL was still installed didn’t make the cut.

    However, I’m wondering if the next time I upgrade PA, I will have to remove DTL again or not. 🆒

    Anyway, thanks for your effort and have a nice day!

    S.L.


 

6
Online

9.8k
Users

6.0k
Topics

36.6k
Posts

Copyright © 1998-2018 ConeXware, Inc.
All rights reserved. Privacy Policy