PA2009 11.03: Shell Ext Missing in Vista x64



  • Hello,

    I’ve just set up a new system at home running Vista Business 64-bit. After installing the newest version of PowerArchiver (11.03 currently), the Shell Extensions aren’t showing up in Windows Explorer (or xplorer2 Pro 64-bit).

    Things I’ve tried:

    • Restarting
    • Unchecking and rechecking “Use Explorer Shell Extensions”
    • Manually unregistering and reregistering paShlExt.dll
    • Uninstalling and Reinstalling PA

    At first I thought it might have been due to having DEP enabled for all processes, but scaling it back to the default of essential programs and services didn’t make a difference.

    All settings toggles were done with Explorer (including the desktop process) closed (PA was closed as well for unreg/rereg paShlExt.dll). Nothing works. I have no context menu entries for right-clicking a file or right dragging.

    All this was done with the built-in Administrator account. It with an elevated desktop process by default, so UAC/Virtualization shouldn’t be interfering.

    Other than Office, there’s no other software on the system, and certainly nothing registering a shell extension.

    Possibly related: .cab and .zip files are opening in Explorer instead of PA as well, as if their associations in Vista aren’t taking. I’ll have to double-check my registry later, but I’m almost positive that the in HKCR entries for .cab and .zip are correctly pointing to PACAB and PAZIP, respectively. Is there somewhere else the shell could be overriding what it’s seeing in HKCR to cause this?


  • conexware

    shell extensions have nothing to do with file associations, they are separate parts of program.

    Check PAZIP and in registry and see where is it pointing to… is PowerArchiver in that location?

    What happens when you launch PowerArchiver manually?

    You are running English PA and English Vista?

    thanks!


  • conexware

    also where did you install PA to? (what folder).

    thanks!



  • In HKCR:
    .zip’s (Default) value points to PAZIP.
    PAZIP’s Shell\Open\command(Default) value points to PowerArchiver’s .exe

    English PowerArchiver and Vista.

    PowerArchvier is installed to C:\Program Files (x86)\PowerArchiver.

    Explorer shows PowerArchiver’s icon for .cab and .zip files, but double-clicking them causes them to open in Explorer as compressed folders.

    Opening PowerArchiver manually, I can navigate to and open the files.

    Other types of archives (e.g. .rar, .7z) open in PowerArchiver when double-clicked in Explorer.

    To be honest, I’d rather have the shellex working. My primary archive usage is to right-drag a file (or several) to a destination folder and use the commands on the context menu to decompress them into place.

    I did finally get around to installing another 3rd party shellex last night and it’s working. I might take a gander through things with Nirsoft’s ShellExView and drive around the registry itself to see if anything looks amiss there.

    If I have time, I might also let Process Monitor loose on my system while I try to double-click a .zip and a .cab file to see why Explorer seems to be ignoring the registry.


  • conexware

    Right click on zip file, and select open with menu… that menu can overwrite file associations. Thats what happened probably…

    as to shell extensions, anyone else with same issue?
    Did you try deleting PA registry key and running PA again? It is in HKCU\Software\PowerArchiver… also check if there is anything under HKLM\Software\PowerArchiver and if there is, just delete the key.

    thanks,



  • Re: Associations

    Blast it, it’s xplorer2 not honoring the registry settings. Explorer itself is fine. I thought I’d checked them in Explorer, but I must not have. My apologies for wasting your time. :o

    Re: Shell Extensions

    I’ll try purging HKCU\Software\PowerArchiver and see what I get. I’ll post back in a bit.

    HKLM\Software\PowerArchiver only contains my name and serial number, because I’m not a fan of having to put it in on every user account.



  • Tried deleting everything from HKCU\Software\PowerArchiver and unregistering paShlExt.dll. Closed down Explorer (incl Desktop process). Ran PowerArchiver. Still no Shell Extension. Sad panda.



  • I also installed a recent version of PowerArchiver on Windows Vista Ultimate 64-bit, and I do not have the explorer extensions. I will try some things later, but the exploder right click menu is just some registry entries.


  • conexware

    @MikeSubtle:

    I also installed a recent version of PowerArchiver on Windows Vista Ultimate 64-bit, and I do not have the explorer extensions. I will try some things later, but the exploder right click menu is just some registry entries.

    what folder did you install PowerArchiver in?

    thanks,



  • I installed it to the default for 64 bit: C:\Program Files (x86)\PowerArchiver



  • I found a simple solution, it had to do with Explorer.exe processes still being running when PowerArchiver tries to create the explorer menus. The instructions below will recreate the shell extensions for PowerArchiver in Windows Vista 64 bit.

    1. Close all your running Windows / Applications.
    2. Run PowerArchiver and keep it open
    3. Press CTRL-ALT-DEL
    4. Click Start Task Manager
    5. In Task Manager, click on the Processes tab, then click on “Image Name” column to sort by name
    6. Find all ‘explorer.exe’ and ‘explorer.exe *32’ processes. For each one listed, select it and click the End Process button (or u can right click on each one select End Process). You will notice that the windows TaskBar disappears.
    7.Go back to your open PowerArchiver window, click on Options. Then click on Configuration.
    8. In the Configuration window, find ‘Shell Extensions’ and click on it.
    9. Uncheck 'Use Explorer Shell Extensions’
    10. Hit OK to save that setting.
    11. Click Configuration and click on Shell Extensions again.
    12. Check the 'Use Explorer Shell Extensions’
    13. Hit OK to save that setting.
    14. Close PowerArchiver.
    15. Press CTRL-ALT-DEL and select 'Start Task Manager’
    16. At the very top is the “File” menu in Task Manger. Click File, then click "New Task (Run…)"
    17. In the Create New Task window, type EXPLORER and then hit OK.
    18. You should see the windows TaskBar showing again at the bottom of your screen.
    19. Click on My Computer or whatever to get the file explorer running and find a ZIP file. Right clicking on the ZIP file should now show the “Extract To…” “Extract here…” etc etc menu options.

    Hazaa!



  • bump 🙂


  • conexware

    did you have PA installed previously? And did you restart after 11.03 installation?

    Closing explorer.exe “should” only matter if you had PA installed previously and new shell dll cant replace old one…

    if this was your first PA installation, then there is some Windows bug that makes this not work - or some other softwate that creates the issue (it should always work)… I just tested with our Vista x64 and it worked fine…


  • conexware

    p.s. thanks for making it work 🙂



  • Did a previous version not work with Vista 64? I don’t remember the PA version that I initially installed on this system, but it was a brand new HP computer.
    I remember after the first installation, and that the menus weren’t there because that is the first thing that I use after installing PA. I also did install an update recently and rebooted, and they were still not there after the reboot.


 

0
Online

9.8k
Users

6.0k
Topics

36.7k
Posts