PA2009 B2 - won't Drag-n-Drop multiple files



  • Using PA 2009 Beta 2 (11.00.45) I cannot select multiple files in the archive and drag them to explorer. Doesn’t seem to matter how I select the files - Ctrl-A, Shift-Click or Ctrl-Click. When I click the selection and drag, the multi-select is lost and I get only the file that was clicked on to start the drag operation.


  • conexware

    please try with beta 3 and let us know.

    thanks…



  • @spwolf:

    please try with beta 3 and let us know.

    Am I missing something? I cannot find a beta 3 download, but I’ve seen a few messages indicating that some people are using it already.



  • OK - beta 3 is showing up for me now in the downloads area.

    Unfortunately I get the same behavior. Is anyone able to repro this, or is it just me?



  • @mwb1100:

    Using PA 2009 Beta 2 (11.00.45) I cannot select multiple files in the archive and drag them to explorer. Doesn’t seem to matter how I select the files - Ctrl-A, Shift-Click or Ctrl-Click. When I click the selection and drag, the multi-select is lost and I get only the file that was clicked on to start the drag operation.

    It seems to depend on where you click (before dragging). As a test which should be reproducible, select 5 (contiguous) files within an archive. If you now try to click anywhere on the middle filename (file 3) of the selection, you cannot drag - any other filename of those selected (1, 2, 4 or 5) then it works.

    @mwb1100:

    I cannot find a beta 3 download

    Use the WebUpdate - Help / Check for updates :p



  • @TBGBe:

    It seems to depend on where you click (before dragging).

    Ah! - that led me to what I think is the key. Multi-file drag from an archive works if you have the Preview window closed or if the file you click on to initiate the drag operation does not have a preview.

    If the file you click on to start the drag operation displays something in the preview window, the drag will only get that file.

    Note that behavior only happens for files inside an archive - if you’re just looking at files in a directory the multi-file drag works fine regardless of the preview.


  • conexware

    please check with beta 4 now avail. through web update and let us know if this has been improved.

    thanks!



  • @spwolf:

    please check with beta 4 now avail.

    The problem is still there with Beta 4 (version 11.00.52).



  • @mwb1100:

    The problem is still there with Beta 4 (version 11.00.52).

    My apologies - after a reboot, the problem no longer shows In Beta 4 (v11.00.52).

    Please close this bug as fixed.

    Thanks.


Locked
 

5
Online

9.8k
Users

6.0k
Topics

36.8k
Posts